Fedora Installer not booting on Asus ROG STRIX X470-F


I tried to boot using the Fedora DVD installer on my Asus ROG STRIX X470-F and it never showed me anything, all I saw was the cursor blinking for a very long time, but it never showed me anything, what can cause that? I’m thinking EFI, but I thought that was taken care of a long time ago, so what else could it be?


Hi @jfha73! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

Such a thing happens sometimes, and it often has to do with graphics card. And as you’re talking about Asus ROG – it probably has NVidia’s GPU (and NVidia’s do have some troubles under Linux).

Did you see DVD or LIve USB boot menu with options like “Start Fedora 30 something something” and “Test this media and start …”?

If you didn’t (and used DVD) I would suggest to test booting from Installation USB (I usually use USB, not DVD). Fedora download page has some information how to make Live USB under various OSes.

If you did see installation media boot menu, then I’d offer a couple things to try to boot into installer.

Hi @jfha73 when you boot live usb or dvd you will see three options

  • Start Fedora-Work-live 30
  • Test this media a start Fedora-Work-live 30
  • Troubleshooting
    select troubleshooting and after that —> Start Fedora-work-live 30 in basic graphics mode
    That will be enough to boot up livedvd or liveusb
1 Like

I tried with Fedora 29 and 30, neither of them showed me these options.

No nVidia GPU here, I have an AMD Radeon GPU.

In that case you didn’t burn properly livedvds 29 or 30 .Best will be install livedvd to usb stick with fedora media writer and like that try to boot fedora

1 Like

@jfha73, if you don’t see boot menu options, then it’s a different issue, not a graphics one.

Please try making Fedora Live USB (I’ve linked you to the page with instructions to do so in my first answer) and booting from it.

I tried using the Fedora Media Writing too and that didn’t work either.

I think something in the Linux Kernel doesn’t like something in my hardware because I also tried Ubuntu 18 and 19 and got the same thing.

But I love Linux, I don’t want to have to use Windows just because Linux won’t boot on my machine.

@jfha73, it’s a motherboard, not a laptop, am I right?

You can also try disabling secure boot in BIOS/UEFI settings (though it shouldn’t be an issue, but testing/verifying can be useful) and also booting from both DVD and USB in legacy mode (not UEFI) mode inf your motherboard gives you such an option.

New intel-based MB’s from ASUS do.

I’d say that it’s not exactly a Linux issue as you don’t even see the boot menu. Linux booting starts after you select an option in that menu, as far as I know. This sounds like some bootloader issue.

Do you have access to another pc/laptop for some tests and as a reference?

Also these people seemed to have no trouble at all with your motherboard.

Moreover websearch for “Asus ROG STRIX X470-F linux” provides quite a few results with some benchmarks etc. So it seems Linux works ok on this m/b.

I don’t think so, because after a while of waiting it does say it cannot find any “storage” devices, which tells me the installer doesn’t have the driver for at least the SATA card in the motherboard, I guess I’m going to have to wait until a newer version comes out that does have the drivers for the SATA this MB has.

In BIOS/UEFI try to select AHCI in drive settings. In addition try to disable something like fast boot.
If it doesn’t work and if you want to try if a newer kernel solves the issue, you could try to boot with Fedora Rawhide.


On an ASUS Vivabook Pro with an NVIDIA GTX, I experienced the same issue: inactivity after the initial install log, up to the point where GNOME was being loaded, afterwards the screen blinks and the laptop shuts down.

Starting the installer in “Basic Graphics Mode” worked fine. Afterwards the system could be used at low resolution until the graphics card drivers are installed.

I suspect choosing RAID instead of AHCI in BIOS settings can produce this behavior. AHCI/SATA interface is standard, I’ve never heard about it needing some custom / non-standard drivers – unless you’re using motherboard’s built-in RAID.

So I second @alciregi’s suggestion.

Hi @sodacamper! Welcome to the community! Please have a look at the introductory posts in the #start-here category if you haven’t had a chance to do so.

From my experience, Basic Graphics Mode helps quite often when you can’t start the installer. Of course, it helps only when the issue in with graphics drivers (more often than not when trying to launch installer on newer NVidia and/or AMD graphics card which isn’t yet properly supported by the kernel on the installation media).

1 Like

I don’t know what the problem was, but Fedora 31 does boot on my MoBo, so I guess that solves it.