Installing Docker on silverblue

Hi,
I am new to fedora silverblue. I have encountered some issues when setting up my dev environment when installing docker on my host.
First I am setting up the docker repositories:

sudo dnf -y install dnf-plugins-core
sudo dnf config-manager --add-repo https://download.docker.com/linux/fedora/docker-ce.repo

Since I am on silver blue I “translated” the commands to

rpm-ostree -y install dnf-plugins-core
systemctl reboot
ostree remote add docker-ce https://download.docker.com/linux/fedora/docker-ce.repo
sudo rpm-ostree cleanup -m
sudo rpm-ostree refresh-md

Then I continued with docker desktop installation according to the official guide

I downloaded the latest docker rpm package and run “rpm-ostree install ./docker-desktop-4.30.0-x86_64.rpm”.
First it failed because it could not locate “docker-ce-cli”. After some looking around it looks like the docker repo was not added correctly? I have no idea why. Since I really don’t know much about how fedora and fedora silverblue works, I consulted chat-gpt and added previously missing “/etc/yum.repos.d/docker-ce.repo” with the following configuration:

[docker-ce-stable]
name=Docker CE Stable - $basearch
baseurl=https://download.docker.com/linux/fedora/$releasever/$basearch/stable
enabled=1
gpgcheck=1
gpgkey=https://download.docker.com/linux/fedora/gpg

After that, clearing some cache and reboot (just to be sure) the Docker repo was finally enabled and docker-ce-cli was found.
So I run “rpm-ostree install ./docker-desktop-4.30.0-x86_64.rpm” again but this time it fails with:

Checking out tree 1a1bee9… done
Enabled rpm-md repositories: fedora-cisco-openh264 updates fedora rpmfusion-free-updates rpmfusion-free rpmfusion-nonfree-updates rpmfusion-nonfree copr:copr.fedorainfracloud.org:phracek:PyCharm google-chrome rpmfusion-nonfree-nvidia-driver rpmfusion-nonfree-steam docker-ce-stable updates-archive
Importing rpm-md… done

Resolving dependencies… done
Will download: 140 packages (55.7 MB)
Downloading from ‘fedora’… done
Downloading from ‘updates’… done
Importing packages… done
Checking out packages… done
error: Checkout docker-desktop-4.30.0-149282.x86_64: opendir(local): No such file or directory

And here I am lost. Not really sure why this is happening or how should I fix it.
Does anyone know why the error happens?

Also is this correct way to install docker on the host machine? Or is it recommended to just use it in toolboxes? I wanted to share the docker installation between toolboxes, because I work with docker often so I chose to install it on host.

That won’t work. See Troubleshooting :: Fedora Docs for adding external repositories.

Then rpm-ostree install docker-ce docker-ce-cli containerd.io docker-buildx-plugin docker-compose-plugin should do it.

You can not install it in a toolbox. You need it on the host.

Also, have you tried podman? :slight_smile:

@majk-runs-linux Welcome to :fedora: :handshake:t5:

Basically the same commands as Docker too. Also can use your Dockerfile