Installed Fedora 38 as dual boot on Win11. When I reboot No Windows option


On my workshop / Test Lenovo M900 I had windows 11 Pro installed.

There were 5 Partitions

100M EFI System
16M Microsoft reserved
222.8G Microsoft basic data (C: Drive - Main OS)
667M Windows recovery environment
512.6G Microsoft basic data (D: Drive - Data)

There was also a 200 GB unallocated space that I used to install Fedora 38 on.

The install all went fine and fedora installed perfectly as always.

When I restarted I was expecting to see a Grub menu with Windows as an option like I’ve done 100 times.

However there was no Windows entry and just booted into Fedora.

My partitions now look like this via the fdisk command.

Disk /dev/nvme0n1: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: CT1000P3PSSD8                           
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 1FCB828F-B1D9-4BFD-9C35-91FA29D08658

Device              Start        End    Sectors   Size Type
/dev/nvme0n1p1       2048     206847     204800   100M EFI System
/dev/nvme0n1p2     206848     239615      32768    16M Microsoft reserved
/dev/nvme0n1p3     239616  467493871  467254256 222.8G Microsoft basic data
/dev/nvme0n1p4  467494912  468860927    1366016   667M Windows recovery environm
/dev/nvme0n1p5  468860928 1543921663 1075060736 512.6G Microsoft basic data
/dev/nvme0n1p6 1543921664 1543923711       2048     1M BIOS boot
/dev/nvme0n1p7 1543923712 1546020863    2097152     1G Linux filesystem
/dev/nvme0n1p8 1546020864 1953523711  407502848 194.3G Linux filesystem

I’ve not played around with Grub for a while and was wondering what I need to do to get my windows as an option.

Many thanks in advance.

The partition nvme0n1p6 clearly shows that linux was installed in legacy (MBR) mode on a system that has windows as uefi boot. Grub cannot boot nor even see an OS that was installed with the other boot method

In order to have grub dual boot I would suggest that you first set the bios to boot uefi only (if possible) then reinstall fedora in uefi mode. During the install (or actually while booted to the live installer and before commencing the install) it would be fairly simple to use fdisk to remove partitions 6, 7, and 8 to free that space back up to be available for the install.

Ah damn !!! I totally forgot to set UEFI when installing.

Thanks for being my 2nd pair of eyes. Very much appreciated.

1 Like

Certain words automatically cause a post to be hidden. Simply edit the offending phrase and your post will be acceptable.

1 Like

Look like I can’t edit it.

Anyway, I was just saying thanks :slight_smile:

"I totally forgot to set UEFI when installing.

Thanks for being my 2nd pair of eyes. Very much appreciated."