Installed a new WM and now applications use Alacritty as default terminal

I installed this WM I saw on lemmy GitHub - YaLTeR/niri: A scrollable-tiling Wayland compositor. and it installed alacritty as a dependency. I’m cool with that but when I switch back to gnome and use BoxBuddy to open linux containers in a terminal it launches it in alacritty instead of Gnome’s default terminal. How can I change it to make it use gnome’s terminal without removing alacritty.

Thanks in advance

Check Settings > Apps > Terminal you might be able to choose which Terminal you want.


If that does not work, you would need to check the dconf and see if it is changed to alacritty

Nah. In gnome settings I don’t see an option and in dconf it’s still ‘gnome-terminal’. Maybe it’s a flatpak thing

Can you check the Boxbuddy config? Are there other applications that launch in Alacritty as well?

Not sure where boxbuddy’s config is and I don’t really have any other apps that launch a terminal :confused:

(completely unrelated how I get it to stop auto emojing)

It’s really just a slight inconvenience so it doesn’t matter that much

There’s currently no standard way to set the default terminal. BoxBuddy uses a hardcoded list which does prefer gnome-terminal, but the code looks a little fragile.

Is gnome-terminal still installed? What does which gnome-terminal say?

I meant the default terminal for gnome, I should have specified. It’s console now or kgx I think is the command to launch it

Fedora still uses gnome-terminal by default. GNOME Console (kgx) isn’t in BoxBuddy’s list, so if you removed gnome-terminal and didn’t have any others installed from that list, it shouldn’t have worked at all prior to installing alacritty.