Install Windows from Fedora 37 KDE Plasma

How? I’ve tried the image writer and it doesn’t recognize… I need to go back to windows as this is way to laggy and slow for some unknown reason

Windows need special processing not a simple copy.

Instead, install ventoy and add the Windows ISO to the ventoy partition.

If you are interested in Fedora, try asking about your issue here and provide the technical details about your device and installation. I wonder if you have nvidia graphics and haven’t installed the driver.


to switch back to windows, download the ISO from Microsoft and mount them by open it. you’ll need also an empty, FAT32 formatted USB Stick with at least 8GB.

  1. You’ll need wimsplit. To get it, run in a terminal:
sudo dnf install wimlib-utils
  1. make sure, that the ISO and USB Key is mounted. In this Example, the ISO is Mounted to /run/media/someone/CCCOMA_X64FRE_EN-GB_DV9/ and the Key is mounted to /run/media/someone/WININST/ where ‘someone’ is your username and italic text is the volume Label or Serial Number.

  2. Now run:

rsync -avxP --exclude sources/install.* /run/media/someone/CCCOMA_X64FRE_EN-GB_DV9/ /run/media/someone/WININST/

This will copy all files, except the WIM-File, as it is too big for FAT32 Drive, we must split the wim File in the next step:

wimsplit /run/media/someone/CCCOMA_X64FRE_EN-GB_DV9/sources/install.wim /run/media/someone/WININST/sources/install.swm 4096

eject the USB key - now you have an SecureBoot capable Windows USB Installation Media.

Tested with Windows 10 & Windows 11 OEM Media (Download)

1 Like

cheers mate but cant even install it “Unable to find a match: wimsplit”

Na intel graphics

And how do I install ventoy?

Did you click the link I provided above? it links to ventoy’s docs including install instructions.

Or click here:

The link I already provided above:

Sorry, my fault, the correct command is:

sudo dnf install wimlib-utils
1 Like

With ventoy, or even with just the windows ISO written to USB I have been able to boot the windows recovery or install without all the above manipulation using wimsplit.

The windows ISO does not seem to be a hybrid so you have to set the bios to boot in the appropriate mode (uefi or legacy) to boot correctly for the install. Windows requires a GPT partitioned disk for uefi boot and an msdos partitioned disk for legacy (MBR) boot.

I have never needed this. Installing windows is easy with booting the ISO provided from MS.

I never tried to dd the windows iso.
Etcher warns about windows iso:

I ignored the warning before and got a non bootable USB, and haven’t tried again since then. I now use ventoy.

If the iso is bootable from ventoy then it certainly should be bootable if written to usb device with dd.

The usb device must not have any mounted partitions when written to. I have had failures in writing at times when I failed to dismount the auto-mounted partitions from the usb before using dd to write to it.

Thanks all now how do I delete this post…?

You don’t delete a post when you get the solution, you mark the answer that helped you as solution as reference for future readers.

1 Like