Woeusb fails to create windows bootable usb


I tried to create Windows 10 bootable usb in Fedora 35. But it fails while copying saying that

dd: writing to ‘/dev/sdb2’: No space left on device

Please find complete command execution as shown below. I tried with a working Pendrive of 32GB. And I checked with this USB drive and it didn’t work. Kindly please suggest a solution to fix this at the earliest.

$ sudo woeusb --device Windows10_Pro_en-US_v1909_x64.iso /dev/sdb --tgt-fs NTFS --verbose
trap_return: DEBUG: returning from process_commandline_parameters
WoeUSB v5.1.2
Info: Target device is '/dev/sdb'.
Info: Target partition is '/dev/sdb1'.
Info: Mounting source filesystem...
Info: Wiping all existing partition table and filesystem signatures in /dev/sdb...
/dev/sdb: 2 bytes were erased at offset 0x000001fe (dos): 55 aa
/dev/sdb: calling ioctl to re-read partition table: Success
Info: Ensure that /dev/sdb is really wiped...
Info: Creating new partition table on /dev/sdb...
Info: Creating target partition...Info: Making system realize that partition table has changed...blockdev: ioctl error on BLKRRPART: Device or resource busy
Info: Wait 3 seconds for block device nodes to populate...Cluster size has been automatically set to 4096 bytes.
Creating NTFS volume structures.
mkntfs completed successfully. Have a nice day.
--2021-11-08 22:41:34--  https://github.com/pbatard/rufus/raw/master/res/uefi/uefi-ntfs.img
Resolving github.com (github.com)...
Connecting to github.com (github.com)||:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://raw.githubusercontent.com/pbatard/rufus/master/res/uefi/uefi-ntfs.img [following]
--2021-11-08 22:41:35--  https://raw.githubusercontent.com/pbatard/rufus/master/res/uefi/uefi-ntfs.img
Resolving raw.githubusercontent.com (raw.githubusercontent.com)...,,, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1048576 (1.0M) [application/octet-stream]
Saving to: ‘/tmp/WoeUSB.tempdir.Psx2lQ/uefi-ntfs.img’

uefi-ntfs.img       100%[===================>]   1.00M  4.95MB/s    in 0.2s    

2021-11-08 22:41:35 (4.95 MB/s) - ‘/tmp/WoeUSB.tempdir.Psx2lQ/uefi-ntfs.img’ saved [1048576/1048576]

dd: writing to '/dev/sdb2': No space left on device
1025+0 records in
1024+0 records out
524288 bytes (524 kB, 512 KiB) copied, 0.358362 s, 1.5 MB/s
ERROR: The command "dd if="${download_directory}/uefi-ntfs.img" of="${uefi_ntfs_partition}"" failed with exit status "1", program is prematurely aborted
Info: Unmounting and removing "/tmp/woeusb-source-20211108-224125-Monday.ISJgCy"...
Info: Unmounting and removing "/tmp/woeusb-target-20211108-224125-Monday.CWs2sX"...
umount: /tmp/woeusb-target-20211108-224125-Monday.CWs2sX: not mounted.
Warning: Unable to unmount "/tmp/woeusb-target-20211108-224125-Monday.CWs2sX".
Warning: Some mountpoints are not unmount/cleaned successfully and must be done manually
Info: You may now safely detach the target device

Device detail in Disks:

It appears like it tried to write a 1MB file to a 524KB partition.

It looks like it is a problem with woeusb that is fixed but not yet released.

Since it is just a shell script you could probably make that change to your local copy.

1 Like

Try using this tool.

if a second box running windows is available:

part one:
open a terminal with admin rights

type the following commands step by step

list disk
select disk N # adjust the correct number
detail disk # to check you’re on correct disk/USB Stick
create partition primary
format fs=ntfs quick

part two:
mount the windows dvd and copy the content to the usb stick

you could shorten the commands after diskpart has started, e.g.

lis dis
sel dis N
detai dis
cre par pri
for fs=ntfs quick

works the same !

ventoy works as well (tested yesterday)
read up the docu to create a data partition for drivers/tools.
- if you want feed the win10 box with full featured driver -