Install PXE/kickstart - invalid or corrupt kernel image


I have a batch of servers and I try to automate Fedora 31 install with PXE/tftp/kickstart.
It works with others OS (Centos, Debian, Ubuntu…) but not really with Fedora31 on some servers models.
On screens, I got the message “invalid or corrupt kernel image”

I have this problem (at least) with DELL R640, DELL DSS1510, DELL R730 and QUANTA X10E-9N, but it works perfectly with Quanta S5HF/T22HF
I downloaded vmlinuz and initrd.img on official mirrors, I tried with the ones in /releases/31/Server/x86_64/os/isolinux/ and with /releases/31/Everything/x86_64/os/isolinux/ too, but still the same error.

In PXE logs, I can see the vmlinuz is downloaded by the server, but nothing else after, so I think the problem comes from the vmlinuz I use. I checked it with md5sum and it’s OK
I have no idea of how to solve this issue, or how to dig it more or have more logs

I hope someone can give me tips about this

Thank you in advance :slight_smile:

Additionnal information: it works with the netinstall iso

But still no idea about how to make my pxe/kickstart working with vmlinuz/initrd.img files