I just want to install a regular Fedora Workstation system using a Kickstart file as if I did interactively but I'm unable to do it

I know Fedora Workstation isos don’t recognize Kickstart files so I have to use a Server’s one with a Kickstart file pointing to “Everything” repo online. BUT:

1. I want the same default btrfs partition layout as it is implemented in a standard interactive Workstation installation but “fedora-live-base.ks” (https://pagure.io/fedora-kickstarts/blob/main/f/fedora-live-base.ks) doesn’t have it inside. Do you know which Kickstart lines would be necessary to achieve this?

2.- Using the Server iso + Kickstart file, my laptop wifi adapter isn’t automatically configured to connect to my open wifi net once system is installed. In fact, it isn’t even recognized!! (while if doing a standard interactive Workstation installation it works flawessly). Do you know which Kickstart lines would be necessary to get wifi just working? (I suspect I’m missing some options of “network” directive (https://docs.fedoraproject.org/en-US/fedora/rawhide/install-guide/appendixes/Kickstart_Syntax_Reference/#sect-kickstart-commands-network)

Thanks a lot




Thanks, I saw that too, but this Kickstart file isn’t used by any of other Kickstart files (via %include sentence, at least) so I infered it’s not a reference. It’s a clue, anyway, thanks!

However, my wifi card problem is what bothers me the most because in a normal Workstation installation is recognized without problem but in a Server+Kickstart one it’s not (and as a consequence, obviously, in a installed system it’s not automatically attached to my open wifi net)

Thanks again

1 Like

maybe I am misunderstanding you but that is not the ks file that is used for installation. that one is used to fire up the live system.

if you look in /root/anaconda-ks.cfg you find for example:

ignoredisk --only-use=sda
autopart --encrypted
clearpart --none --initlabel

I would suggest using the Everything netinstall instead of the Server one. FCIX Micro Mirror


Thanks all of you.

Finally, I’ve been able to achieve the partitioning with btrfs in my Kickstart file as if I were chosen the automatic partition scheme in the interactive workstation anaconda installer. This problem is gone now.

BUT there’s the other one, still (the most important, in fact): my wifi adapter isn’t recognized on the installed system via Kickstart + netinstall/server iso (it’s the same) but when I do the installation using interactive workstation anaconda I haven’t any problem.

In specific, if I put this Kickstart line:
network --onboot=yes --bootproto=dhcp --hostname=fedora34 --device=wlp0s12f0 --essid=SuperXEiLL --activate I infer it’s ignored because the wifi configuration panel appears on screen to activate manually a connection to a wifi network. What is the most strange is that after that the installation succefully connects to wifi and downloads required packages without problem but when I reboot the recently installed system, wifi card is gone. Maybe must I install some driver/firmware package explicitely, maybe in %pre section? How can I know what Anaconda does in this step to achieve what I want to achieve in Kickstart?

Thanks a lot again and sorry for disturbing you.

I’ve been reading up on kickstart files in Wikipedia, and learned that when you do a normal interactive installation, you end up with a kickstart file that can be used for other installations on other machines with the same hardware. And, that you can easily edit the file to add or remove things as needed. Have you tried using that kickstart file with instructions to install the appropriate driver for your wifi adapter added?


Thanks a lot. When I was trying things I read that file but I didn’t find anything special. But maybe I ignored something…I’ll try again.

Meanwhile, I’ll mark this issue as solved because I don’t think there’s much more solutions to look

Thanks a lot all of you.

It sounds like your kickstart file needs to include the driver for the wifi card. Probably another package to install since it is available but just not part of the netinstall bundle. The net install apparently does not have that by default while the workstation install iso does.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.