How to set up CoreCtrl

Hi there,

I installed CoreCtrl, I read the instructions on how to
get Full AMD GPU controls, from here,

I don’t want to mess with my Grub, so I used Grub Customizer, I added the

GRUB_CMDLINE_LINUX_DEFAULT= amdgpu.ppfeaturemask=0xffffffff

I assumed it has to be the exact line “GRUB_CMDLINE_LINUX_DEFAULT”
and not just “GRUB_CMDLINE_LINUX”; so I added it at the end. (maybe that is my mistake?)

I typed in

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Because that is where the Customizer says Grub is located. I got no errors,
I rebooted.

But when I go into CoreCtrl, I still get this.

No more extra controls than I had before.

I leave a neofetch.

OS: Fedora 32 (Thirty Two) x86_64
Host: Inspiron 5570
Kernel: 5.7.8-200.fc32.x86_64
Uptime: 27 mins
Packages: 1645 (rpm), 5 (flatpak)
Shell: bash 5.0.17
Resolution: 1920x1080
DE: Xfce
WM: Xfwm4
WM Theme: Default
Theme: Arc-Dark-solid [GTK2], Adwaita [GTK3]
Icons: Yaru [GTK2], Adwaita [GTK3]
Terminal: xfce4-terminal
Terminal Font: Monospace 12
CPU: Intel i5-8250U (8) @ 3.400GHz
GPU: Intel UHD Graphics 620
GPU: AMD ATI Radeon R7 M260/M265 / M340/M360 / M440/M445 / 530/535 / 620/625 Mobile
Memory: 1857MiB / 7850MiB


As far as I know, the way you try to modify kernel parameters does not work anymore like this, since: Changes/BootLoaderSpecByDefault - Fedora Project Wiki

Manual way:
You should “sudo su” and “cd /boot/loader/entries/”, then append at the end of the options line of the entry you want to change (depending on active kernel versions): amdgpu.ppfeaturemask=0xffffffff

Managed way:
In fact you should do something like:

sudo ls /boot

sudo grubby --args=“amdgpu.ppfeaturemask=0xffffffff” --copy-default --update-kernel=vmlinuz-5.7.0-1.fc33.x86_64

You could remove it with:

sudo grubby --remove-args=“amdgpu.ppfeaturemask=0xffffffff” --copy-default --update-kernel=vmlinuz-5.7.0-1.fc33.x86_64

At least, that is what I would try. :wink:

1 Like

I tried, gave no errors,

it did not take either,

Thx, I’ll keep trying.