Can't get advanced settings to show up in CoreCTRL despite ppafeaturemask=0xffffffff

Tried to edit etc/default/grub to add GRUB_CMDLINE_LINUX_DEFAULT="quiet radeon.si_support=0 amdgpu.si_support=1 amdgpu.dpm=1 amdgpu.ppfeaturemask=0xffffffff"

Did not work 2 years ago, does not work any better now.

2 Years ago I solved it in this reddit thread by doing :

grubby --update-kernel /boot/vmlinuz-5.3.15-300.fc31.x86_64 --args="amdgpu.ppfeaturemask=0xffffffff"

“vmlinuz-5.3.15-300.fc31.x86_64” being replaced by current kernel of course, 5.15.4-201.fc35.x86_64.

After a reboot the command :

printf "0x%08x\n" $(cat /sys/module/amdgpu/parameters/ppfeaturemask)

returns : 0xffffffffSo it looks like it worked and should show the advanced settings now accordingg to the indications on CoreCTRL’s Wiki.

And yet CoreCTRL “Advanced mode” does not look like this :

But instead, just like before the ppafeaturemask append, shows just the basic Wattage limit slider and power profile selection.

This is making my head explode, that something that worked 2 years ago doesn’t now, and I have no idea why … thanks in advance for any help!

As indicated by u/rompottikeisari on reddit, it seems like it is a kernel level bug that will be patched in the near future :

Kernel 5.16 Release Candidate already include those patches and work from rompottikeisari’s account. Marking this as the solution.