How to make Steam use Nvidia dGPU under Wayland?

(This post is more curiosity than any real need, because everything is working okay for me in X11.)

I’m running Fedora 37 Workstation on a Dell Inspiron 7610 with an Nvidia RTX 3060. Nvidia drivers and Steam are installed from RPMFusion. Under X11, Steam uses the dGPU as expected. But under Wayland, Steam uses the iGPU. I tried “Launch using Discrete Graphics Card,” but this doesn’t seem to make any difference as to which GPU a given application uses, either under Wayland or X11. Seems like each app just runs on the GPU it chooses, regardless of that “Launch…” option. (Most use the iGPU, though Chrome uses the dGPU, and Xorg or Gnome use the dGPU. I’m basing all this on the output of nvidia-smi.)

Is there something basic I’m missing? Most posts I find related to this topic seem to suggest that Steam should be able to use the Nvidia card even on Wayland, although there is this one comment from Jeff V saying that some applications don’t use the dGPU under Wayland but do under X.

After more testing, I realized this has nothing to do with Wayland vs. X. That was just coincidence. My best current guess, in case it’s helpful to anyone else, is that a game uses the dGPU if I start Steam first, then the game. If I start the game first, it uses the iGPU. Oddly, clicking “launch using discrete graphics card” still seems to have no effect on whether the dGPU is actually used, in either Wayland or X.