How i managed to install Nvidia driver

I have tried a lot of not working guides to install nvidia driver on my:

[john1@fedora envycontrol]$ inxi -F
  Host: fedora Kernel: 6.1.60-200.fc38.x86_64 arch: x86_64 bits: 64
    Desktop: Cinnamon v: 5.8.4 Distro: Fedora release 38 (Thirty Eight)
  Type: Laptop System: LENOVO product: 81RS v: Lenovo Yoga S740-14IIL
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI: LENOVO v: BYCN39WW date: 05/28/2021
  ID-1: BAT0 charge: 63.9 Wh (97.9%) condition: 65.3/62.0 Wh (105.3%)
  Info: quad core model: Intel Core i7-1065G7 bits: 64 type: MT MCP cache:
    L2: 2 MiB
  Speed (MHz): avg: 1232 min/max: 400/3900 cores: 1: 3613 2: 3850 3: 400
    4: 400 5: 400 6: 400 7: 400 8: 400
  Device-1: Intel Iris Plus Graphics G7 driver: i915 v: kernel
  Device-2: NVIDIA GP108M [GeForce MX250] driver: nvidia v: 535.113.01
  Device-3: Chicony Integrated Camera driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.9 driver: X:
    loaded: modesetting,nvidia unloaded: fbdev,vesa dri: iris gpu: i915
    resolution: 1: 1920x1080~60Hz 2: N/A
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.1.9 renderer: Mesa Intel Iris
    Plus Graphics (ICL GT2)
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel Ice Lake-LP Smart Sound Audio
    driver: sof-audio-pci-intel-icl
  API: ALSA v: k6.1.60-200.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.83 status: active
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi
  IF: wlp0s20f3 state: up mac: 04:33:c2:02:de:51
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
  IF: enp0s13f0u1u4 state: up speed: 1000 Mbps duplex: full
    mac: 4c:e1:73:42:1f:6b
  Device-1: Intel AX201 Bluetooth driver: btusb type: USB
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: 04:33:C2:02:DE:55 bt-v: 5.2
  Local Storage: total: 1.86 TiB used: 312.69 GiB (16.5%)
  ID-1: /dev/nvme0n1 vendor: Micron model: MTFDHBA1T0TCK size: 953.87 GiB
  ID-2: /dev/sda vendor: Western Digital model: WD10EARX-00N0YB0
    size: 931.51 GiB type: USB
  ID-3: /dev/sdb vendor: Kingston model: DataTraveler 2.0 size: 14.54 GiB
    type: USB
  ID-1: / size: 37.39 GiB used: 24.62 GiB (65.9%) fs: ext4 dev: /dev/nvme0n1p7
  ID-2: /boot/efi size: 259.5 MiB used: 131.2 MiB (50.6%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 16.67 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p9
  ID-2: swap-2 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 56.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 321 Uptime: 12m Memory: total: 16 GiB note: est.
  available: 15.17 GiB used: 3.15 GiB (20.7%) Shell: Bash inxi: 3.3.30

and finally this guide was the solution:

Guide that worked for me

I have cinnamon and in rightclick Menue of a game there is “…run with eGPU” and thats my second nvidia card …

Is in german “dedizierter GPU” = eGPU ???

Don’t ask why the usual way to install nvidia was a mess, I’m totally noob , especially on Fedora

Happy again :slight_smile:

The official docs are from the RPMfusion probject that provides the nvidia drivers for Fedora.

This is the guide that you are recommended to follow: Howto/NVIDIA - RPM Fusion

1 Like

That depends on the context. If eGPU means external GPU and “dedizierter GPU” means “dedicated GNU”, that looks different.

If i recall it correct i used what rpmFusion suggest and that failed. Don’t ask me why. it failed and now i have a nice working install of nvidia driver: “never touch a running system!”

Thanks for your answer!