How do I customise desktop zoom on Fedora?

I have just installed Fedora on another HP Probook laptop. My original older model laptop has Zorin Linux on it and I installed Compiz on it so I could use desktop zoom. Not sure how to do this on Fedora. I enabled zoom through accessibility settings however I don’t know how to assign shortcut keys. Is there some documentation that describes all this?

Also it appears that Fedora may support Mate Compiz window manager. How do I switch to that from the default?


1 Like

Hi Glenn! Sorry, I’m not very familiar with Mate/Compiz, but to your question about shortcut keys, you definitely can! Press Super or use the Activities button/hot corner to get to the Overview, then type “keyboard shortcuts” and pick the top choice:

Which will jump you to the Keyboard section of the Settings app. From there, click “View and Customize Shortcuts” at the bottom - you can pick a category of shortcut from there, and by choosing Accessibility you can see the default shortcut for “Turn zoom on or off”, and change it if you wish:

To your question about documentation that can help discover/describe features, the built-in GNOME Help app actually has quite a bit of content in it - e.g. if you search “zoom shortcut” it will bring you to a help page with that default shortcut listed, and info on how to get to the Settings app to customize:

Hope this helps!


I am not using Mate, just the vanilla Fedora desktop. However when I click zoom it wants to go in increments of 25% whenever I press the zoom+ shortcut key combination and I don’t know where to change it to a smaller increment.

Hmm, I don’t know if the shortcut key increments are easily editable in a UI, but the toggled on-off zoom level can be manually changed in that dialog box by clicking into it and typing a new value, if that helps?

I found that but as soon as I leave that panel the shortcut keys change back to 25% zoom increments.

That panel and the shortcut keys are different and can have different scaling factors. Editing the value in the panel does exactly what you tell it. Then using a shortcut key reverts to the value for which the key is configured. The panel does not alter the settings for the keys.

Ok, how do I alter just the scaling factor for the shortcut zoom keys?