How can I change terminal font in than desktop environment?

I’m using Fedora30 on my laptop, but the characters on screen is too small when I get into the CLI by typing Ctrl + Alt + F3(or other numbers). So I tried to change the font following instructions as:

  1. in shell, type the command: setfont /lib/kbd/consolefonts/ter-m32n.psf.gz
    It worked well, ONLY until I turned my laptop off.
  2. In /etc/sysconfig/i18n, define SYSFONT=“ter-m32n”(actually my OS does not have this file, so I made it, which I don’t know that is helpful.)
  3. In /etc/vconsole.conf, set the line which starts with FONT=<whatever_font> as FONT=“ter-m32”
    and then later, I read the article(Hwo to increase the size of tty font - #2 by nightromantic) and followed the instructions. But it STILL failed.

Can someone please help me(and my eyes)? I cannot find other solutions to this problem.
P S Oh, and the most big font in my device is ter-m32n, but a little bit bigger thing would be nice. Do you have any recommendations, or any other solution for sizing up character size on screen? :wink:

I think that should be ter-m32x
where x is
So it would need to be:

Hi, @jujuland and welcome to Ask Fedora!

The thing that should permanently help you is described in the post you’ve linked to in the Setting font as the default console font section points 4 through 6.

As far as I know, vconsole.conf sets font only for virtual console – i.e. what you see inside a terminal applications in a graphical environment.

The easiest / surest way to set font for terminal consoles - i.e. ttys accessed with [Ctrl]-[Alt]-[F3] etc. is by setting font as kernel boot parameter – and I’ve described how to do it in that post.

I personally use it to increase font size and to display my native language’s symbols properly.

If that didn’t work for you – let’s check together why – as it’s sure work for me (for a several years now).

1 Like

Thanks for feedback! I tried once more as you said. My settings for it is as:

  1. In /etc/vconsole.conf

  2. In /etc/default/grub
    GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora-swap rhgb quiet vconsole.font=/lib/kbd/consolefonts/ter-m32n.p sf.gz"

and finally type this command sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

I first tried only with font name, ‘ter-m32n’ and then tried again with the absolute path of the font(/lib/kbd/consolefonts/ter-m32n.psf.gz). Both way failed.

Oops, yes. Thanks. I typed wrong. But I typed right in my setting files.

In my vconsole.conf and /etc/default/grub I specify font name without path or file extension. Example in man vconsole.conf is the same, without filepath and extension. I suggest you try the same.




GRUB_CMDLINE_LINUX="... rvconsole.font=LatGrkCyr-12x22 rhgb quiet"

Also note that kernel parameter in /etc/default/grub is rvconsole.font and not vconsole… like in your post, note the first r letter.


I’m sorry to be late. I recently changed the setting you said, and it worked! I guess that rvconsole, not vconsole was the point. Anyway, now I can read on my console clearly. Thanks a lot!

1 Like

You’re welcome! I’m glad you’ve resolved your issue! )

Also please mark the thread as solved (by marking one of the posts), it can help others with similar problems to find answer quicker.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.