Hotspot Popup window

i see attached popup window which open and then closed automatically and i do not know why it is do that and how can i stop this window from opening
Screenshot from 2023-05-07 15-41-19

1 Like

The popup window “Hotspot Login” is a sign of using a captive portal, but this can also happen due to connectivity related problems, content filtering, or tampered HTTP response.

1 Like

i just install fresh fedora 38 and do not know how to check that

2 Likes

thanks for your support i will check solution

1 Like

It is good that there is a solution, but it is strange that, at least for me, this only started happening very recently. Has something changed in Fedora that makes the popup appearing more likely?

Edit: I am using a wired connection, but I also have wifi on this PC, and have that connected as well, because why not? My understanding is that the wired connection takes precedence in this case. However, the other day I was playing an online game, and when the hotspot window popped up, the other player was disconnected from the game session at the same time. It could have been coincidence, but maybe there is some sort of bigger intermittent network issue at play here?

1 Like

As usual the same happened just now, but this time the window stuck around for maybe ten seconds or so.

Thats pretty odd. Fedora infrastructure doesn’t use nginx anywhere…

Are you behind a web proxy of some kind?

i was execute this solution and popup does not appeare any more but internet frequently drop then restart automatically

i connect directly to wifi and this message appear in different network

I don’t use proxies or VPNs of any kind.

ok. Can you attach the output of the following command:

journalctl -b -u NetworkManager | tail -100

after this window pops up? Perhaps that will tell us whats going on…

Sure, I’ll paste it below. I think around the 20:51 timestamp is when the problem happened.

I had a thought. I have an nginx server running on my local network with port forwarding from my router to that server. Could there be a network or DNS hiccup on my machine that causes the request for fedoraproject.org/static/hotspot.txt to go to my local network instead?

touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.3792] manager: rfkill: WWAN enabled by radio killswitch; enabled by state file
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.3792] manager: Networking is enabled by state file
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.3795] settings: Loaded settings plugin: keyfile (internal)
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.3807] dhcp: init: Using DHCP client 'internal'
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.3809] manager: (lo): new Loopback device (/org/freedesktop/NetworkManager/Devices/1)
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.3816] device (lo): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.3819] device (lo): state change: unavailable -> disconnected (reason 'connection-assumed', sys-iface-state: 'external')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.3823] device (lo): Activation: starting connection 'lo' (8e21c762-f8fe-427a-a28f-03815e6ce052)
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.3828] manager: (enp7s0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/2)
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.3834] settings: (enp7s0): created default wired connection 'Wired connection 1'
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.3835] device (enp7s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.4103] device (wlp5s0): driver supports Access Point (AP) mode
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.4106] manager: (wlp5s0): new 802.11 Wi-Fi device (/org/freedesktop/NetworkManager/Devices/3)
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.4108] device (wlp5s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.6178] device (wlp5s0): set-hw-addr: set MAC address to E2:22:46:C7:B6:C1 (scanning)
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8127] device (lo): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'external')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8129] device (lo): state change: prepare -> config (reason 'none', sys-iface-state: 'external')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8130] device (lo): state change: config -> ip-config (reason 'none', sys-iface-state: 'external')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8135] modem-manager: ModemManager available
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8136] device (lo): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'external')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8146] device (lo): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'external')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8147] device (lo): state change: secondaries -> activated (reason 'none', sys-iface-state: 'external')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8150] device (lo): Activation: successful, device activated.
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8426] device (wlp5s0): supplicant interface state: internal-starting -> disconnected
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8426] Wi-Fi P2P device controlled by interface wlp5s0 created
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8427] manager: (p2p-dev-wlp5s0): new 802.11 Wi-Fi P2P device (/org/freedesktop/NetworkManager/Devices/4)
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8428] device (p2p-dev-wlp5s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8430] device (wlp5s0): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
touko 12 20:36:42 uranus.home NetworkManager[5121]: <info>  [1683913002.8432] device (p2p-dev-wlp5s0): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:44 uranus.home NetworkManager[5121]: <info>  [1683913004.5696] agent-manager: agent[7817c0c993dc29a0,:1.35/org.gnome.Shell.NetworkAgent/42]: agent registered
touko 12 20:36:45 uranus.home NetworkManager[5121]: <info>  [1683913005.5629] device (enp7s0): carrier: link connected
touko 12 20:36:45 uranus.home NetworkManager[5121]: <info>  [1683913005.5631] device (enp7s0): state change: unavailable -> disconnected (reason 'carrier-changed', sys-iface-state: 'managed')
touko 12 20:36:45 uranus.home NetworkManager[5121]: <info>  [1683913005.5644] policy: auto-activating connection 'Wired connection 1' (cc5f7962-fd61-30e7-804e-7ef3e03518a8)
touko 12 20:36:45 uranus.home NetworkManager[5121]: <info>  [1683913005.5648] device (enp7s0): Activation: starting connection 'Wired connection 1' (cc5f7962-fd61-30e7-804e-7ef3e03518a8)
touko 12 20:36:45 uranus.home NetworkManager[5121]: <info>  [1683913005.5649] device (enp7s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:45 uranus.home NetworkManager[5121]: <info>  [1683913005.5650] manager: NetworkManager state is now CONNECTING
touko 12 20:36:45 uranus.home NetworkManager[5121]: <info>  [1683913005.5651] device (enp7s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:45 uranus.home NetworkManager[5121]: <info>  [1683913005.5722] device (enp7s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:45 uranus.home NetworkManager[5121]: <info>  [1683913005.5733] dhcp4 (enp7s0): activation: beginning transaction (timeout in 45 seconds)
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.3892] policy: auto-activating connection 'olympos_5g' (b80bc4df-4f5f-4c5a-864f-6ef4eb9a938a)
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.3896] device (wlp5s0): Activation: starting connection 'olympos_5g' (b80bc4df-4f5f-4c5a-864f-6ef4eb9a938a)
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.3897] device (wlp5s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4019] device (wlp5s0): set-hw-addr: reset MAC address to 34:CF:F6:E2:81:2D (preserve)
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4025] device (wlp5s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4027] device (wlp5s0): Activation: (wifi) access point 'olympos_5g' has security, but secrets are required.
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4027] device (wlp5s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4033] device (wlp5s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4034] device (wlp5s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4036] device (wlp5s0): Activation: (wifi) connection 'olympos_5g' has security, and secrets exist.  No new secrets needed.
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4036] Config: added 'ssid' value 'olympos_5g'
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4036] Config: added 'scan_ssid' value '1'
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4036] Config: added 'bgscan' value 'simple:30:-70:86400'
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4036] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256 FT-PSK SAE FT-SAE'
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4036] Config: added 'auth_alg' value 'OPEN'
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4036] Config: added 'psk' value '<hidden>'
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4231] device (wlp5s0): supplicant interface state: disconnected -> inactive
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4231] device (p2p-dev-wlp5s0): supplicant management interface state: disconnected -> inactive
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4328] device (wlp5s0): supplicant interface state: inactive -> authenticating
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4329] device (p2p-dev-wlp5s0): supplicant management interface state: inactive -> authenticating
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4794] device (wlp5s0): supplicant interface state: authenticating -> associating
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4794] device (p2p-dev-wlp5s0): supplicant management interface state: authenticating -> associating
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4900] device (wlp5s0): supplicant interface state: associating -> 4way_handshake
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.4900] device (p2p-dev-wlp5s0): supplicant management interface state: associating -> 4way_handshake
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.5408] device (wlp5s0): supplicant interface state: 4way_handshake -> completed
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.5409] device (wlp5s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network "olympos_5g"
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.5409] device (p2p-dev-wlp5s0): supplicant management interface state: 4way_handshake -> completed
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.5630] device (wlp5s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.5635] dhcp4 (wlp5s0): activation: beginning transaction (timeout in 45 seconds)
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.6806] dhcp4 (enp7s0): error parsing DHCP option 42 (ntp_servers): wrong option length 13
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.6806] dhcp4 (enp7s0): state changed new lease, address=192.168.1.36
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.6809] policy: set 'Wired connection 1' (enp7s0) as default for IPv4 routing and DNS
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.6963] device (enp7s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.6978] device (enp7s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.6979] device (enp7s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.6984] device (enp7s0): Activation: successful, device activated.
touko 12 20:36:46 uranus.home NetworkManager[5121]: <info>  [1683913006.7843] manager: NetworkManager state is now CONNECTED_GLOBAL
touko 12 20:36:49 uranus.home NetworkManager[5121]: <info>  [1683913009.2219] dhcp4 (wlp5s0): error parsing DHCP option 42 (ntp_servers): wrong option length 13
touko 12 20:36:49 uranus.home NetworkManager[5121]: <info>  [1683913009.2220] dhcp4 (wlp5s0): state changed new lease, address=192.168.1.171
touko 12 20:36:49 uranus.home NetworkManager[5121]: <info>  [1683913009.2462] device (wlp5s0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:49 uranus.home NetworkManager[5121]: <info>  [1683913009.2475] device (wlp5s0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:49 uranus.home NetworkManager[5121]: <info>  [1683913009.2477] device (wlp5s0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
touko 12 20:36:49 uranus.home NetworkManager[5121]: <info>  [1683913009.2483] device (wlp5s0): Activation: successful, device activated.
touko 12 20:36:49 uranus.home NetworkManager[5121]: <info>  [1683913009.2487] manager: startup complete
touko 12 20:36:52 uranus.home NetworkManager[5121]: <info>  [1683913012.0467] agent-manager: agent[99f11815350fbbb2,:1.82/org.gnome.Shell.NetworkAgent/1000]: agent registered
touko 12 20:51:47 uranus.home NetworkManager[5121]: <info>  [1683913907.1576] manager: NetworkManager state is now CONNECTED_SITE
touko 12 20:51:47 uranus.home NetworkManager[5121]: <info>  [1683913907.1587] manager: NetworkManager state is now CONNECTED_LOCAL
touko 12 20:51:47 uranus.home NetworkManager[5121]: <info>  [1683913907.1591] manager: NetworkManager state is now CONNECTED_SITE
touko 12 20:51:47 uranus.home NetworkManager[5121]: <info>  [1683913907.1594] policy: set 'olympos_5g' (wlp5s0) as default for IPv4 routing and DNS
touko 12 20:51:47 uranus.home NetworkManager[5121]: <info>  [1683913907.6990] manager: NetworkManager state is now CONNECTED_GLOBAL
touko 12 20:51:47 uranus.home NetworkManager[5121]: <info>  [1683913907.6993] policy: set 'Wired connection 1' (enp7s0) as default for IPv4 routing and DNS
touko 12 20:51:48 uranus.home NetworkManager[5121]: <info>  [1683913908.2632] manager: NetworkManager state is now CONNECTED_SITE
touko 12 20:51:48 uranus.home NetworkManager[5121]: <info>  [1683913908.2636] manager: NetworkManager state is now CONNECTED_LOCAL
touko 12 20:51:48 uranus.home NetworkManager[5121]: <info>  [1683913908.2638] manager: NetworkManager state is now CONNECTED_SITE
touko 12 20:51:48 uranus.home NetworkManager[5121]: <info>  [1683913908.2639] policy: set 'olympos_5g' (wlp5s0) as default for IPv4 routing and DNS
touko 12 20:51:48 uranus.home NetworkManager[5121]: <info>  [1683913908.2915] manager: NetworkManager state is now CONNECTED_LOCAL
touko 12 20:51:48 uranus.home NetworkManager[5121]: <info>  [1683913908.2916] manager: NetworkManager state is now CONNECTED_SITE
touko 12 20:51:48 uranus.home NetworkManager[5121]: <info>  [1683913908.2916] policy: set 'Wired connection 1' (enp7s0) as default for IPv4 routing and DNS
touko 12 20:51:49 uranus.home NetworkManager[5121]: <info>  [1683913909.1245] manager: NetworkManager state is now CONNECTED_GLOBAL
touko 12 22:12:14 uranus.home NetworkManager[5121]: <info>  [1683918734.9276] agent-manager: agent[ff47be890b43158e,:1.82/org.gnome.Shell.NetworkAgent/1000]: agent registered
touko 12 22:48:48 uranus.home NetworkManager[5121]: <info>  [1683920928.6927] agent-manager: agent[943e708efe87a10c,:1.82/org.gnome.Shell.NetworkAgent/1000]: agent registered

Adding to the previous: I don’t think it’s my nginx server. Just now I happened to stumble on to a Reddit post showing the same thing.

You need to isolate the problem to identify its cause, and multiple simultaneous connections do not help, but instead create additional points of failure due to possible software related race conditions and hardware related issues due to increased power consumption.

Test each connection separately on a long term, i.e. hours/days, with connectivity check enabled and specifically note cases when connectivity changes in the NetworkManager log.

If this happens on the wired connection, you likely need to replace the network cable, or troubleshoot/replace the upstream network device serving the wired link.

ok, well, some things to check:

  • check your nginx server logs. Is there a request for hotspot.txt at the right time coming from your internal network?

  • does it happen all the time? or sporadically? When it next happens, try a 'curl -v http://fedoraproject.org/static/hotspot.txt and see what ip it got and what answers it.

You can of course disable the check as others may have noted… ‘dnf remove NetworkManager-config-connectivity-fedora’ and restart NetworkManager.

This being a hardware issue is, while not impossible, relatively unlikely in my opinion, considering it affects more than just me (Reddit post, another Reddit post, another thread here as well as other people in this current thread). For multiple people to suffer the same kind of hardware failure all at the same time seems unlikely. I disabled the wifi connection and will see if the problem still persists, but either way it seems likely to me that there is something more to this problem.

Good tip. I checked, and saw no requests for hotspot.txt in logs going back several days.

It’s been happening about once or twice a day. I don’t know of I’ll be able to react quickly enough to curl anything. The window lingering long enough for me to screenshot it was definitely an anomaly. Usually the window just flashes very quickly and closes immediately.

Sure, but that seems like sweeping the problem under a rug. I’d prefer to fix it if possible.

Reported on rhbz: 2203156 – hotspot screen pops up randomly

I didn’t find any reports upstream.

It seems that there are changes related to hotspots in NetworkManager 1.42.6 (see /usr/share/doc/NetworkManager/NEWS), which reached F38 ~3 weeks ago.

There was no change in the /usr/lib/NetworkManager/conf.d/20-connectivity-fedora.conf file from NetworkManager-config-connectivity-fedora package between 1.42.4 and 1.42.6. So it’s probably code changes in NetworkManager itself. Someone more familiar with NM will have to look into it.

2 Likes

I have the same problem! is it a problem?

Do you get the exact same pop up window? Does it say aws nginx?

Can you take a screenshot?