Help with accessible installation using Orca

Hello,

I’m a blind screen reader user attempting to install Fedora with the Orca screen reader. I’ve done this years ago so am pretty sure it is doable, but that was years ago so I can’t remember the exact steps.

Specifically, I’m having trouble booting the live CD to a graphical environment. I can see enough to know when the screen lights up for X/Wayland vs. stays dark for the console, and it never gets to this point on the F29 workstation live image. I can borrow a working pair of eyeballs at some point, but before doing that, I’d like to do all I can on my end.

I’ve tried the live CD on a couple USB sticks, and with a few writes. I also tried the Silverblue installation media before discovering (or at least suspecting) that didn’t include Orca. The Silverblue installer at least booted to its installation screen, so I don’t think my issue is the USB.

I’m wondering if there are any manual steps I need to take during the boot process to reach the live desktop? I.e. do I press Enter, any key combinations to launch the live CD vs. a rescue image, etc.? I suspect there may be some key combination I’m missing in order to launch the live session.

If there isn’t, then I’ll get help. I’m also open to any non-graphical installation options that would get me a graphical environment in the end. I know there’s a text-based installation, but I don’t think it lets me modify partitions, and I’d prefer a single root partition with no swap. Maybe someone could generate a template kickstart file for me, but then I’d have the issue of adding it to the boot parameters without speech feedback, unless there’s some way to modify the boot parameters on my USB media and embed the kickstart file there.

Thanks for any help.

Hi Nolan,
It has been awhile since I saw you around the discussions. In the case of the live usb for F29 workstation, it boots up in the selection menu normally highlighting the check media then run fedora live option. If you arrow up that is the option to run the live media without checking it first, or arrow down (from the default selection) is the troubleshooting option which brings up a CLI. If you do nothing the live image will be checked then ran automatically in 30 seconds. For my brother in law who is only able to see using his peripheral vision, and mostly with his right eye, I was able to get him started via a phone call. I’ll ask him what he is doing about the screen reader since I know he uses it generally and has been running Silverblue for over a month quite happily.

1 Like

Hey, thanks, that helped. If I selected the option to not check the media, I was up and running in a minute or so. For some reason, checking the media hung, and nothing was visible even after half an hour or so. Not sure how long a media check should take.

Hope I can continue posting on this same thread for help. I finished the installation, and am now in regular Workstation. I then set about doing the side-by-side installation method for Silverblue with the eventual intent of removing the workstation install and using only Silverblue.

When I boot into Silverblue, though, nothing talks. I can kind of see the contrast if I launch gnome-terminal, and typing in my username/password, just hitting enter and typing my password, and various other combinations never gets me to a screen where Alt-f2 “gnome-terminal” reveals any contrast to me. So I suspect I’m not logging in.

One thing that occurs to me–how does Fedora know that the initial GNOME setup was completed? I’m wondering if the side-by-side instructions place whatever files may be necessary in the new deployment to complete that step? So maybe I’m being made to go through the initial setup again. If that’s the case, what files should I copy from my workstation installation to skip that step? I seem to recall this broke back when I used Silverblue F28 and upgraded to F29, and at the time I was building a new computer and pondering experimenting with Chrome OS, so I don’t remember what the suggested solution was or if it would have worked.

I also don’t see /usr/bin/orca in the ostree directory for my deployment, so I suspect I may have to layer Orca into the installation. I do have Orca master running in my home directory, so it’s possible that I may be able to use that once logged in, but I need to figure out how to get past the initial setup on my own first.

Thanks for the help.

As far as I know, that is a file in the user directory of the installation. You should be able to find it in the .config directory of your home. It will be a file called, funny enough, gnome-initial-setup-done. If you cat it you should see yes%. If that file isn’t there or contains no% I would guess that the side-by-side installation missed it.

Yes I believe Orca will need to be layered. I am uncertain how it would handle being a flatpak due to access limits to the system, but maybe it can do everything through Dbus, I haven’t looked at that project.

Do you just end up at a blank screen? I’ll do some digging into that on my end later tonight if I get a chance. At the least you should be able to access a terminal so you could poke around a bit. At the least it would tell you if your install is Okay.
One thing I am uncertain on is how well the mapping of your workstation home transfers to your silverblue home. Being that /var and /etc are the only writable areas of a Silverblue install. First let’s try to find out what is being done and how far the Silverblue installation get’s in it’s startup.
Come back once you have some more info, you started this thread, so until you close it, it’s going to stay open for you. We can use this to help move through the issues. Another note on initial setup of Gnome, if it isn’t already done, it is the first thing you encounter even prior to logging in once the GDM is started. You can’t normally login if you don’t have an initial user setup.

Hmm, so initial-setup doesn’t run if any directory under /home has
this file? I definitely do, so perhaps my home directory isn’t being
mounted correctly.

I’m hoping to get sighted help in the next day or two, but in the
meantime, is it possible to use rpm-ostree to layer in Orca from outside
the ostree? I.e. can I layer in Orca from my main Fedora installation,
preferably without creating a new deployment since I’d rather not have
to copy files from /ostree/deploy/fedora/deploy/OLD_UUID to NEW_UUID?
Unless the process will do that for me even from outside of an ostree
boot. If I can layer in Orca then I can do a bit more debugging.

Also, given that I want to replace this Workstation installation with
Silverblue, what should I do with my current /home directory to move it
into the ostree when booted from a live CD? I tried moving it into
/ostree/deploy/fedora/deploy/29780e7de4cc7ba9f3136e81309681e703bc4dc44e75439247dec65c661f02e7.0/var/
such that var/home/nolan existed, but that didn’t seem to get me
anywhere. I have the following in
/ostree/deploy/fedora/deploy/29780e7de4cc7ba9f3136e81309681e703bc4dc44e75439247dec65c661f02e7.0/etc/tmpfiles.d/00rpm-ostree.conf:


L /var/home - - - - ../sysroot/home

With my home directory at /home, this also doesn’t seem to work.
Wondering if perhaps these instructions are outdated and no one has
tested this process in a while? I noticed one spot where I needed to
replace atomic: with fedora:, so that’s a distinct possibility.

Anyhow, as stated, I’m hoping to get sighted help soon. But I’ve got a
couple decades of Linux experience under my belt, so I figured I’d
exhaust all possible avenues on my own before getting help from
non-Linux-experienced folks. :slight_smile:

Hi nolan,
With rpm-ostree you certainly can try to layer Orca. There will likely be dependencies pulled in which is normal. The concept of Silverblue is to allow for this very thing to occur. In the purist sense, perhaps layering is “verboten” but for pragmatic reasons I find it very useful. Especially for this type of necessity that could be some time before it is flatpak’ed if it can even be.
I am going to be starting the very thing you are asking with the move of an existing Fedora 29 workstation on a Dell Inspirion laptop to Silverblue including the home directory retention. I am doing this to write an article about it for fedora magazine, in preparation for the release of F30. So I’ll keep you in the loop as I go along. It will start in a couple of days likely.

Perfect, thanks, I’ll wait for that article and please do keep me
posted! The need to switch back to Fedora and reinstall was kind of
forced on me by circumstance, so I’ll probably stick with this
workstation install until this busy period has passed, then re-attempt
finishing the conversion. I imagine the article will be done by then. :slight_smile:

Hey, just wondering how the article was going? Been doing OK with stock
F29, but would really like to switch to Silverblue.

Thanks!

Hi Nolan,

I haven’t gotten through it yet. I am doing the leg work this weekend providing I don’t have to service any machinery. So far I have a laptop setup with F30 workstation, I will reply back here with the gory details for you.
EDIT 20190614 09:57EDT
So after trying to strangle my Dell Inspiron 1501 into submission, I decided to try it using a VM. it seems reasonable. Anyway, to use the LiveUSB in a VM is not so simple a task for installing over the running VM. There is a comment here by @gn0mish that they were able to install SB29 with manually partitioning and specifying the home to remain /home. I am uncertain how well this is handled in the case of an LVM say, which was something I had wanted to test. If you already have a mount point for /home, I think you should be Okay to use the manual partitioning to specify it, but I would personally backup my home directory (tar it off to a USB storage device) as a fail safe. As a caution, you could also backup your /etc directory to external storage as well, since there may be some info there you desire to keep across installs. Then do the install of the latest SB using the media writer. I am going to keep trying to get the Dell working to test this from end to end, but I think the backup home and etc directories then install is the best option at this point, certainly the cleanest.