GTK Styles button missing in KDE

Under application Style there is no gtk Styles button shown. how to fix? Kde-gtk-config is installed.

In Application Style select the three dot menu that is located to the right of the “Configure Icons and Toolbars” option.

There’s no 3 dot menu located as shown in your picture in my settings.

Can you share a screenshot? You can copy paste from spectacle

It will not show up when you just install a “Application Style”. The icons you see there are previews of the official installed Global Theme.

If you just want to install additional application Styles, you have to do it as @pjolt shows on his Screenshot.

If you installed it you get a pull down field where you can select and apply it. The preview button is beside it. But you will definitely need this 3 dots to get there :slight_smile (are you using Kinoite?):

If you have no dots then your window is big enough to show the text on the button:

1 Like

Please reinstall the Breeze theme again. When I try to remove it it takes to much away from KDE specific packages.

We can not help if you not tell us what exactly you changed or how you installed your system.

1 Like

Will try reinstalling breeze later, I installed kde as below, possibly something I left out :

sudo dnf install plasma-desktop plasma-nm konsole screen wl-clipboard kinfocenter dolphin dnfdragora plasma-discover sddm && sudo systemctl enable sddm

Did you install from everything network iso?

There is also a group to install it, right?

sudo dnf groups list |grep -i kde
   KDE Plasma Workspaces
   KDE Frameworks 6 Software Development

Full of bloatware, unlike on debian there’s no full standard or minimal desktop options just the take it or leave it workspaces option, that’s why I installed the way I did, I’m sure I’ve left one obvious thing out as everything else is working fine

Added netinstall

You realized that we are on Fedora, right?

If you miss it here help to make it possible!

soo, on Fedora Kinoite, which is minimal but not broken, I have these packages installed:

rpm -qa | grep gtk
breeze-gtk-common-6.0.4.1-1.fc40.noarch
breeze-gtk-gtk3-6.0.4.1-1.fc40.noarch
breeze-gtk-gtk4-6.0.4.1-1.fc40.noarch
gtk-update-icon-cache-3.24.41-1.fc40.x86_64
unity-gtk-module-common-0.0.0+17.04.20170403-18.fc39.noarch
ibus-gtk3-1.5.30-1.fc40.x86_64
libcanberra-gtk3-0.30-35.fc40.x86_64
gtk3-3.24.41-1.fc40.x86_64
xdg-desktop-portal-gtk-1.15.1-5.fc40.x86_64
libdbusmenu-gtk3-16.04.0-27.fc40.x86_64
gtk4-4.14.4-1.fc40.x86_64
gtkmm3.0-3.24.9-1.fc40.x86_64
libunity-gtk3-parser-0.0.0+17.04.20170403-18.fc39.x86_64
unity-gtk3-module-0.0.0+17.04.20170403-18.fc39.x86_64
ibus-gtk2-1.5.30-1.fc40.x86_64
adwaita-gtk2-theme-3.28-19.fc40.x86_64
breeze-gtk-gtk2-6.0.4.1-1.fc40.noarch
gtk2-engines-2.20.2-29.fc40.x86_64
gtk2-2.24.33-18.fc40.x86_64
libcanberra-gtk2-0.30-35.fc40.x86_64
kde-gtk-config-6.0.4-1.fc40.x86_64
ibus-gtk4-1.5.30-1.fc40.x86_64
libappindicator-gtk3-12.10.1-4.fc40.x86_64
libportal-gtk4-0.7.1-3.fc40.x86_64
vte291-gtk4-0.76.1-4.fc40.ptyxis.x86_64
gtksourceview4-4.8.4-6.fc40.x86_64

On his first topic he mentioned it :blush:

1 Like

Uninstalled it, rebooted and reinstalled Kde-gtk-config and it’s showing up now for some reason.

1 Like

Did you install any dependencies before, like a GTK theme? Maybe the package just works when there is another one.

This would then need to be added as at least recommended or hard dependency.

No. Nothing else installed.

Check your dnf history and also post the output of rpm -qa | grep gtk just to have a real solution.

1 Like