Grub "overflow is detected" error on boot

I installed fedora 35 last night and I found two bugs - the first I managed to fix after hours of trial and error, but the second one has me stuck.

When I boot up my computer, as soon as fedora starts booting (even before it asks me for my disk encryption password) this error message pops up:

error: …/…/include/grub/misc.h:296:overflow is detected.

I tried googling it, but it came up with absolutely nothing.
I can still boot to the desktop, but the message shows every boot.

Please could someone help me fix it, or at the very least, failing that, hide it?


Welcome to ASK!

When I see this kind of grub boot errors, it is when I create the /boot partition as a btrfs subvol.

Would you please post the output of:

lsblk -f

Hi, if your system during the session login generally working fine, maybe you would consider to upgrade first with sudo dnf upgrade. There some upgrade packages available related to grub and let see if the problem still there or not

Hey, sudo dnf upgrade tells me I’m fully up to date, and there are no updates to install

The other thing, maybe you want also to regenerate grub.cfg with sudo grub2-mkconfig -o /boot/grub2/grub.cfg. Take a look during the process, is there any error messages or not?

I ran that command and this is what it said:

I still have the error on boot though

I think I know the problem. If your system are using UEFI as image print screen you provided above, it’s because the /EFI/efi/fedora folder are directly inside /boot/efi instead mounting it from different partition.

Ideally it should be like:

│    vfat   FAT32       4708-4B7F                             532.1M    11% /boot/efi
│    ext4   1.0   boot  7125543f-b29c-42c7-b18f-bb4733adc895  622.2M    29% /boot

The sda1 is FAT filesystem which is an EFI paritition then mounting it to /boot/efi instead it become one partition.

Using this tutorial: How to find Linux is under BIOS or UEFI mode ? - UnixArena I just checked and it said I’m using BIOS, not UEFI. Maybe that has something to with it?

As it technically seems to work despite the message, is there any way I could disable grub messages/warnings so I’m not notified every boot?

From your partition layout, look like you’re using BIOS/MBR boot system.

For how on disable grub error messages, I’m sorry I don’t know how. But when I find on how to do it, I’ll inform you here.

Okay, thanks for your help, hopefully I’ll figure it out

1 Like

I just want to check with your current system. Would you like to post the result of:

# Run `sudo parted /dev/sda`
[rizal@fedora ~]$ sudo parted /dev/sda
GNU Parted 3.4
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.

# Then type `q` and enter. Below are my system with BIOS/GPT.  
# I would like to know about your system in part `Partition Table:`
(parted) p                                                                
Model: ATA ST9320325AS (scsi)
Disk /dev/sda: 320GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt    #<---------------------This part
Disk Flags: pmbr_boot

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  2097kB  1049kB                     bios_grub
 2      2097kB  1076MB  1074MB  ext4
 3      1076MB  320GB   319GB   btrfs

# To exit parted, type `quit` and enter.

If the part Partition Table said MBR or other than GPT, it’s make me remember when I’m still using other distro before switching to Fedora on my BIOS boot system, It will give some messages (but I’m forget what the messages is) before eventually it booting normally. And as you said, It’s harmless (at least for what I need).

The problem gone when I convert it to GPT. But it’s bit confusing on how to do it. If you have other disk, maybe you could test it by make blank GPT partition layout first.

1 Like

Hey again, I typed in those commands and that line is:

Partition Table: msdos

I have a second disk laying around, so I’ll try installing it with GPT and see if that helps. If it works I can convert my main install.
Thanks for the idea

You’ve fixed it! I reinstalled fedora on another disk like you suggested, but I used the exact same settings and it worked perfectly, so I realised that my disk is probably failing. It’s a good job I didn’t just ignore the error as I could have lost my data if it failed completely. So I’ll just use my backup drive instead.

Thanks for all your help

Great! But since you’re use same exact settings and not change to GPT (as I guessed), I mark your comment as solution instead of mine. So the other user will not mislead if they have same exact problem.