Grub does not show new kernels after dnf upgrade

After some extensive googling and not finding a solution I thought I should ask here.
So what happened is, I ran sudo dnf upgrade but after waiting for 10 minutes on an SELinux scriptlet I decided to abort the upgrade process. Not the smartest move I know.

After rebooting I ran sudo dnf upgrade again, where I ran into Error: Transaction check error on glib2.
That one I fixed with this: sudo rpm -e --nodeps glib2-2.58.2-1.fc29.i686.

After that sudo dnf upgrade ran without a problem as far as I could tell.

Now the problem:
rpm -qa kernel gives me:
kernel-5.6.12-300.fc32.x86_64 kernel-5.6.13-300.fc32.x86_64 kernel-5.6.14-300.fc32.x86_64

But grub (efi btw) gives me only Kernel 5.6.12, recovery, and my windows partition.

What I tried
sudo dnf reinstall kernel = This reinstalled kernel 5.6.14 for me → no change in grub
Resetting and reinstalling grub = This changed nothing
sudo bang my head on the table = Did not help.

Any ideas? Thanks!

Exactly what commands did you run to regenerate the grub config?

sudo dnf reinstall grub2-efi shim
sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg