GPU Fans Spike to 100% Under Load and Stay Locked at that RPM

Any help is massively appreciated, this has been an intense and long standing issue. This is a continuation of a thread I made on EndeavourOS several months ago (I am now on Fedora after having experienced this same issue across several distros) - GPU Fans Ramp to the Moon And Stay There Without Reason - Kernel & Hardware - EndeavourOS

Gigabyte 1660 Super graphics card maxes out the fan speed to 100% unnecessarily when under load - Temperatures will be 50c or even lower at times and the fans will ramp rapidly to max, and stay pegged there. Even after rebooting, the fans are still locked at a high RPM until I shut the computer down completely.

Windows does not have this problem, and I’ve gone through UEFI settings several times so it does seem something specific with Linux.

I’ve tested this with multiple games (GTAV, Genshin Impact, Yuzu, etc) and it can occur in any of them (so it’s not just a Proton/Steam issue).
I’ve tried several different kernels (5.10, 5.13, 5.15, 5.17, 5.18)
I have tried several different Nvidia drivers (475, 495, 470, 510)
Affects all attempted distributions (Arch, Fedora, Mint, Pop!)

I’ve confirmed kernel options like blacklisting noveau and setting nvidia-drm.modset, I’ve also attempted modifying the “Coolbits” settings to use with GreenWithEnvy, but Green can’t see what the fan RPM is (even after running lmsensors). It unlocks overclocking and I can set a fan profile, but Green can’t actually see the fan RPM and the fan profile is ignored.

Here is a video of it happening, keep sound on as you can hear the GPU when it ramps up (may need to turn up volume to hear) -

Please let me know if anyone has ideas, wants more info, etc. I’d really love to try and get this fixed.