GPG check FAILED Google Chrome

Hello.
After upgrade Fedora from Fedora 37 to Fedora 39(via Fedora 38), I try to install google chrome:

dnf install fedora-workstation-repositories
dnf config-manager --set-enabled google-chrome
dnf install google-chrome-stable

And then Error:
Downloading Packages:
[SKIPPED] liberation-fonts-2.1.5-7.fc39.noarch.rpm: Already downloaded                                  
[SKIPPED] google-chrome-stable-120.0.6099.224-1.x86_64.rpm: Already downloaded                          
google-chrome                                                             81 kB/s |  14 kB     00:00    
GPG key at https://dl.google.com/linux/linux_signing_key.pub (0x7FAC5991) is already installed
GPG key at https://dl.google.com/linux/linux_signing_key.pub (0xD38B4796) is already installed
The GPG keys listed for the "google-chrome" repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.. Failing package is: google-chrome-stable-120.0.6099.224-1.x86_64
 GPG Keys are configured as: https://dl.google.com/linux/linux_signing_key.pub
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: GPG check FAILED

I tried to “dnf clean package”, but i have the same error.
I don’t want use option --nogpgcheck, because this is not secure! I want to understand, why i have problem with GPG check.

History:
"I had previously installed the Google Chrome repository in Fedora 34. However, I encountered an error and uninstalled Google Chrome before upgrading to Fedora 38. Now, after upgrading to Fedora 39, I want to reinstall Google Chrome properly. Could it be possible the old GPG key is conflicting with the new one? What steps should I take to remove the old GPG key and reinstall Google Chrome correctly?
Thanks

Google uses a somewhat unusual method of managing their GPG keys. They install a cron script at /etc/cron.daily/google-chrome. My guess is that something went wrong with that script.

You probably want to download the keys and rpm package manually from https://dl.google.com/linux/linux_signing_key.pub and Google Chrome - The Fast & Secure Web Browser Built to be Yours and inspect them since the automated system failed.

2 Likes

Thank you for good article, i removed two gpg keys and dnf suggested install new gpg keys.