Gnome Wayland automatic login for single-application mode (kiosk mode) is not working after Log Out

The default user in Workstation Live is liveuser without any password and in Gnome is set for automatic login as it should be according to Gnome Help

$ cat /etc/gdm/custom.conf 

But if one logs out and logs in again, one is greeted with the classic GDM greeter for liveuser… (Scott user below is just a screenshot grab from a search engine result)

I’m not quite sure if this Fedora Discussion thread Automatic passwordless login in Gnome 43.0] is related or not…

Any ideas ?

Automatic passwordless login is for booting only.
Once the user logs out then they must enter their password to log in again.

An exception would be if that user had no password assigned. That would then mean the system would be very insecure since anyone at the keyboard could log in as that user.

Thanks @computersavvy

It is indeed designed for a kiosk use like Gnome Kiosk “Kiosk provides a desktop enviroment suitable for fixed purpose, or single application deployments like wall displays and point-of-sale systems.”

In case a logout/login is required (without any password set) it would be a better user experience to avoid the need to clic on the GMD greeter but to directly land into the session

Most of the documentation dates back to X-11, I’vz found nothing on Wayland so far.

Would you have any sources ?

If setting this up as a kiosk then you should manage the ability to log out and prevent a user getting to the login screen as you state above. In fact disabling everything but a power off or restart would be ideal.

A kiosk is managed much different than a desktop since the intent would be to only allow access to a specific app or set of apps and prevent access to the underlying OS.

Does this work in wayland? It should work very similar to X11 but since wayland is new I have no clue.

Sorry I didn’t quite understand what you mean …

I will look into it. Any link to get me started ?

To cover logout you could try setting:

It doesn’t seem to work. My /etc/gdm/custom.conf is:


Thanks @grumpey anyway

That’s odd, it works on my install, wonder if it’ something to do with the liveuser…

You can take a look here, Chapter 20. Restricting the session to a single application Red Hat Enterprise Linux 8 | Red Hat Customer Portal