Gnome settings automatically set unwanted keyboard shortcut that cause conflict with another keyboard shortcut


Im using fedora 34 with gnome desktop environment. And so far everything works great except one problem and i cant figure it out or find proper solution on internet. Without further ado…
Im using two language keyboard layouts. One for coding and other one for writing in my native language. And to switch between them i want to use my favorite shortcut that im used to. Which is hold [ctrl][shift] and than press [space] to toggle between them.

Inside Gnome->settings->keyboard-> Customize shortcuts
When i set shortcut keyboard for “switch to next input source” to [ctrl][shift][space] it automatically set “switch to previous input source” [ctrl][space]. And vice versa. Despite of fact im using only two keyboard language layouts so one way or another both do same thing switch from one to other one. (i dont need [ctrl][space])

Now there starts the problem - keyboard shortcut [ctrl][space] is shortcut for Ulauncher. And that cause conflict.

I was trying to google some solution. But all i found was:

  1. “just set it in gnome settings”
    But there as mentioned above i cant set one to [ctrl][shift][space] without automatically set other one to conflicting [ctrl][space].
    Also… if i remove one [ctrl][space] it automatically removes other one.

  2. Use gnome tweaks tool → Keyboard and mouse-> Additional layout Options ->switching to another layout.
    But there are only some predefined combinations neither of i like.

  3. Also i found advice to set it inside some config file but that was for another distribution and of course that file does not exist on my fedora installation. So i thought maybe someone could help here specifically for fedora ?

To summarize . question is:
Is it possible to set [ctrl][shift][space] for keyboard layout switch but unset [ctrl][space] so i can use [ctrl][space] for Ulauncher ?

Thanks for reading. I appreciate any help before ill be forced to get used to different shortcut.



You can open dconf and change ‘Switch to previous source’ to not use the default option and make it anything else from /org/gnome/desktop/wm/keybindings/switch-input-source-backward.

Then in settings ‘Switch to previous source’ should become disabled. You should now be able to use [ctrl+shift+space] for anything you like. I guess it’s not an ideal solution but it works for me.

Here is a screenshot:

Hope it works for you. Cheers.

1 Like

Okay i took a look to dconf you suggested.
→ /org/gnome/desktop/wm/keybinds/
→ switch-input-source
→ switch-input-source-backward

Interestingly enough default option for “switch-input-source-backward” was unchecked.
And when i check it ON → “use default value” result is:

At this point I have my [ctrl][shift][space] for keyboard layout switch. I have [ctrl][space] for Ulauncher. and i can ignore [shift][super][space].

That is fine fix for my problem! \(^-^)/
Thank you very much

1 Like