Gnome GUI finds updates, But Terminal says no updates

if i use terminal to check updates there is no updates so it seems all good, but when i use Gnome GUI it finds lots of updates on system

no testing repos activated so wierd why CLI wont see updates, but Gnome GUI sees updates

I’m on KDE plasma spin, same thing happened. Do the update through the gnome software, it should be fine.
I suspect both are using different mirrors, do you also have fastestmirror=True in your dnf.conf?

Do you have offline updates enabled by any chance?

havent edited any dnf.conf files nor offline updates those are system defaults

Someone with gnome will need to chime in here for clarification.
I think, offline-updates are the default on fedora currently.

You can do offline updates on the terminal with:

sudo dnf offline-upgrade download
sudo dnf offline-upgrade reboot

Gnome Software shows flatpak updates, while dnf does not, so it could be some flatpak with available update.

1 Like

Yes, Flatpak updates are not shown in dnf output, but shown in GNOME Software.

Apart from that, both GNOME Software and dnf should display the same content. You can make both refresh the output - use the circle arrow in GNOME Software, and use sudo dnf update --refresh.

They should both show the same content in the sense that they access the same repos. Do PackageKit and dnf share a common database, i.e. a common local view of what’s in the repos, though?

i used gnome GUI to update full system before it does everything today i was on CLI doing stuff so wanted to run updates there results was no updates and then opened Gnome GUI and see it has updates waiting to be installed so downloaded all and restarted system.

not sure where and what issue is, but need to monitor if this hapends more often

Each uses its own cache for the metadata and has its own refresh schedule for that metadata. Thus the cache may be out of sync with each other, but if updated as indicated by @kparal in post #6 each may be forced to update that cache. Once the cache update is done they both should show the same info except for the flatpak packages as already noted.

If using dnf on the cli you should always use dnf upgrade --refresh to ensure the latest updates are seen. Similarly with gnome software gui the process noted above will allow you to see the latest updates before doing the actual package upgrades.

1 Like

When you say CLI, how do you run your updates there? Are you using dnf to update? Are you using flatpak additionally to update flatpaks?

Sudo dnf update && sudo dnf upgrade

Can’t remember what was the updates some lib packages that GUI had and CLI didint so might be flatpak related. Mostly I use gnome GUI since it does all in one

Then the difference between GUI and CLI is Gnome GUI finds updates, But Terminal says no updates - #5 by augenauf

The GUI reboots to install updates. Some updates won’t take effect until the system is restarted, so there is a needs-restarting command-line tool you can run to see which programs will need a reboot.

The choice I made was to never install gnome-software and perform the 3 types of updates manually as root.

dnf update --refresh
flatpak update
fwupdmgr refresh --force
fwupdmgr get-updates
fwupdmgr update

The metadata automatic update is also disabled

systemctl disable dnf-makecache.timer
systemctl disable fwupd-refresh.timer

This along with other settings makes it so my computer is quiet until I initiate communications. Also the double storage of yum repo metadate for both dnf and packagekit (gnome-software) is foregone. And where I don’t use appstream-data that also never gets downloaded.

For other people I’ve just let gnome-software and dnf-system-upgrade.service handle it. All privacy and security comes down to choices you are comfortable with making. Making sure you make an informed decision is hard.

so seems like dnf on cli still updates flatpaks or something i checked first on GUI it shows discord and freedesktop updates i run sudo dnf update and same time i hit enter it started install GUI updates, but CLI output is nothing to do. seems like it runs all, but output shows nothing to do

edit
after hitting refresh on GUI i get lots more updates system updates etc CLI still says nothing to do

I agree 100% with @steppybug

I almost never use the gnome software gui even though installed.

I instead simply use the dnf and flatpak commands on the cli and thus never have a concern about ‘mismatched’ data in the caches. I always use the dnf --refresh upgrade command so I am 100% certain the metadata used for the update being done is 100% up to date at the time I perform the update.

I am running into the same issue once in a while. Just now, dnf update --refresh did show no updates available, while Gnome Software showed a bunch of updates available.

Those available updates are rpms, no flatpaks or whatever. So I just wonder and would like to understand the reason behind this.

We constantly see similar comments and there are many threads here asking an identical question.

To make the long story short.
Gnome software uses its own cache that is separate from the dnf cache for metadata, and both update on differing schedules. This means that mismatches often are seen.

If a user always uses one or the other the difference in offered updates are not an issue, but switching back and forth results in the displayed differences (which are usually only because the metadata cache has not been updated to be in sync).

When using dnf to maintain the updates one additional step is required. Flatpaks are not updated directly by dnf but also require the flatpack command to perform updates. Gnome software gui updates both flatpak and rpm packages at the same time.

1 Like

I just did updates to F40 using Gnome Software (so rebooted to install updates) . Immediately after the second reboot I ran dnf update, which installed adwaita-icon-theme-legacy-46.2-1.fc40.noarch (which is on your list) and updated 28 packages.

Then I used Gnome Software on another F40 system. It installed the packages that were missed by Gnome Software on the first system. dnf reports:

Last metadata expiration check: 2:17:40 ago on Fri May 31 08:45:57 2024.
Dependencies resolved.
Nothing to do.
Complete!
1 Like

Did you activate the refresh button (upper left corner) in Gnome Software?