Gnome defaults to X11 and uses software rendering on Intel Iris Pro 6300


I recently upgraded to Fedora 37 with Gnome 43. However, the problem I am writing about was also present on Fedora 36 with Gnome 42. I haven’t tried any previous versions of Fedora.

The issue is rather simple, I have an older PC that I use for development with an Intel Xeon Processor E3-1285L v4 CPU and integrated graphics.

However, it seems Gnome has no hardware acceleration with this configuration and defaults to X11.
What I would like to know is how to debug the problem? What should I be looking for and how? I would like to run Gnome with Wayland and HW acceleration.

Intel-media drivers are installed and seem to work. I followed the guide here: Intel Graphics - Best practices and settings for hardware acceleration?

Thank you very much! I will follow any instruction you give me to debug the issue.

EDIT: I partially found the reason why I am defaulting to software rendering. I am mainly connecting to the machine via XRDP and the XRDP version in Fedora36/37 defaults to software rendering. It doesn’t seem to have glamor enabled to have hardware rendering.

Still not sure why I am defaulting to X11 instead of Wayland. I couldn’t find any rules, though the reason is definitely rules related as I get the “exec-conditions” error for wayland.

I also figured out why I was defaulting to X11.
Turns out I had two windows managers installed:
lightdm and gdm
For some reason, Fedora was set to default to lightdm and on my system, Wayland doesn’t work with lightdm only with gdm.
After I switched to gdm by doing
systemctl disable lightdm.service
systemctl enable gdm.service
everything worked fine.

1 Like