Wayland F37

How do I switch to Wayland from xorg?

My Display is on X11 and I cant play games on X11 the FPS is very low.

I have tried

sudo nano /etc/gdm/custom.conf WaylandEnable=True change False to True

nothing happend. What do I do?

1 Like

Hi, @maasi!

If you are using GNOME Desktop, you need to change session on your login screen(where you typing password). In right bottom corner you can see a settings icon and you will see some options like “GNOME on Xorg”, you need to choose “GNOME”.

After that you just type your password and you will load to GNOME Wayland.

Notice: Most games are running through XWayland layer, that means you probably get less FPS than on Xorg(X11).

thank you for answering

they are GNOME and GNOME classic and both of them are x11, non have wayland.

Just “GNOME” is wayland session

I am in Gnome session an it x11.

I want to change it to wayland. In F36 it was wayland and I could play games with it but 2 day ago I installed F37 and stock with x11.

Thats wierd, "GNOME’ must be with wayland by default

any idea how I can change it to wayland?

Wayland normally is the default session. If your graphical card is not supported on Wayland, Xorg will be the only option. NVidia support for Wayland, for example, is very recent, and then likely some types still may not work.You may want to indicate which graphical card you use.

There was an issue with F37 where wayland was not enabled and systems were forced to xorg only. There were posts while 37 was still Beta here, but I thought that had been fixed. I seem to recall that it was related to specific laptop hardware.

I have not verified the info, but users should be able to locate related info with a search on this forum.

here is my Graphics info

Device-1: Intel HD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia
v: 470.141.03
Device-3: Chicony EasyCamera type: USB driver: uvcvideo
Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.5 driver: X:
loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa dri: iris gpu: i915
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 22.2.3

It appears you are running nvidia and have not updated the nvidia driver for many many months since the 470 driver was released at about the same time as fedora 34 was in use. The 470 driver does not support wayland at all. Wayland was only supported by nvidia with the release of the 495 and later drivers. If you want to use wayland you must update the nvidia driver. You do not say where you installed the nvidia driver from.

If directly from nvidia using the .run file then you will need to uninstall that and reinstall the latest driver from the rpmfusion repo so it installs the latest driver and will in the future keep it updated for the kernel version you have installed. If you already installed it from the rpmfusion repo then a simple sudo dnf upgrade akmod-nvidia will upgrade to the latest version and everything should work from that point, including using wayland. The latest nvidia driver is 520.XX.

The rpmfusion repo can be enabled from the gnome software app by enabling 3rd party repos; or by following instructions here, after which the dnf command can be used to install the nvidia drivers. sudo dnf install akmod-nvidia

Note that having the drivers installed from the nvidia site then also from rpmfusion may cause problems. It is always best to remove the older driver before installing the rpms from rpmfusion.


thank you

I dont know how it downgrade, I had 520xx with F36. I have removed and reinstall nvidia, now I have 520xx. Wayland is Display put games are still at low FPS.

Related to low performance, maybe double-check that the games you’re playing are running off of the nvidia card as opposed to integrated graphics? Steam handles that by default when launching games, others might need explicitly chosen from the app launcher by right-clicking > choosing “Launch Using Discrete Graphics Card” or editing the .desktop file for that game to make the nvidia card the default.


yes thank you so much i worked

To install the 470 driver the dnf command would be dnf install akmod-nvidia-470xx. It would replace the newer driver with the older one and lock the version to 470. Some nvidia cards were dropped from support when the 495 driver was released so users of that hardware are required to use the 470 driver to support their cards.