General browser issue?

Hey

Are anyone having trouble launching browsers after a recent update?

I updated a few days back and after that, firefox takes approximately 2 minutes to open.

I refreshed firefox using the refresh button, didn’t work so I removed it and re-installed, didn’t work so I tried the Flatpack version which had the same problem again.

So I figured I can live with that - use another browser until its fixed. Except. Every browser I install has this problem. Vivaldi, Brave, Librewolf… I tried Chromium but that throws a libCanberra error instead and doesn’t open at all.

I think this happened in an update where widevine was installed but I am not certain.

I’ve tried running all browsers from terminal but there is no indication of error. Its simply a delay but everything opens succesfully.

Has anyone experienced anything similar? Or does anyone have any suggestion to how I can troubleshoot this ?

Thanks

I experienced something similar but not quite. Browsers would still launch fine, but certain websites would stall loading for pretty much exactly 2 minutes. The fix for me was to remove Widevine. Or rather, in Firefox it was enough to set media.eme.enabled to false. I don’t know the exact cause and why I have a bit different symptoms than you, but I guess it’s somehow Widevine stalling for 2 minutes for some reason. Luckily I do not use any DRM-encumbered service so I do not need it anyway.

Thanks. I tried disabling media.eme.enabled but it didn’t change the behaviour. I do feel like widevine could be the culprit basically because that is the only browser-adjacent thing that changed recently.

Does anyone know if there’s negative consequences to just uninstalling it ?

Did you also try sudo dnf remove widevine-installer? And/or delete /var/lib/widevine?

DNF remove widevine-installer also removes Firefox because it considers it a dependency. Then, installing firefox it will also install widevine-installer because that again is a dependency… So it seems there is no way to have FF without widevine ?

If I delete /var/lib/widevine I was worried it would just break something more ?

Ok that is definitely not the case on my machine. Haha now I’m worried I have broken something.

If I delete /var/lib/widevine I was worried it would just break something more ?

Guess you could always just rename the folder to test it. If it doesn’t solve the issue, then rename it back.

Tried uninstalling Widevine (and all browsers). Installed Browsers again (and thereby also widevine) and renamed the directory. Didn’t do a thing :frowning:

Is there any logs / journalctl command I can check/use to find out whats holding it up? I’m pretty used to debugging Linux but haven’t used Fedora since Fedora Core 4 times…

This is simply too weird. Its ALL browsers, and JUST browsers, nothing else. I’ve tried now Librewolf, Icecat, Vivaldi, Brave, Firefox, Chromium (got the libcanberra fixed), Ungoogled-Chromium both as packages and flatpaks and its the same behaviour across the board. No errors, no faults, just waits for 2 minutes and then starts

Last idea from me: You could try to do MOZ_GMP_PATH= firefox -P -safe-mode -no-remote and create a new profile and start into that. See if the same behavior occurs.

No difference unfortunately. Thanks for trying though, I appreciate your effort here.

I’ve discovered that if I launch chromium from the terminal, it opens right away (but doing so from the laucnher still has the issue) - it doesn’t work for any other browser, but I can live with this for now.

Hopefully a future update fixes this, whatever it is

1 Like

widevine-installer is not Widevine, it’s just a script that you can use to install Widevine should you choose to. It does enable the pref in Firefox by default, but that shouldn’t do anything until you actually install Widevine. It’s not supposed to break anything or cause browsers to launch slowly. We made it a dependency of Firefox installs so it will be available for users who do want Widevine, without requiring a full logout/login to set up the configs properly (just a browser restart is enough after running sudo widevine-installer).

Are you sure your startup delay issue has anything to do with Widevine? I’ve seen that 2 minute delay thing before, and it’s always due to some dbus-related issue (well before we even had widevine support). That problem is systemwide, and I’ve seen it when I launch a desktop session outside a display manager. That’s why it would affect all browsers. I suspect you’re jumping to unfounded conclusions just because you saw widevine-installer in the update.

You can delete /var/lib/widevine safely, but there should be nothing there in the first place (other than a README) if you haven’t actually run widevine-installer. I really doubt your issue has anything to do with Widevine at all. Instead look for other desktop components that might have been updated, or changes to how you log in / start your session, and things like that.

Hi Hector

Initially I thought it was widevine due to it being the only browser related thing I could see having changed, but the steps I took during this thread convinced me its not. I realized during this what you said about it being an installer, so I actually used it and it didn’t change anything either.

The fact that it affects pretty much all browsers but not chromium when launched from terminal further tells me its not widevine as well.

I am still baffled to what the cause can be. It happened during a two week period where my only reason for turning on the computer was to do updates. Didn’t change anything or launch any apps at all other than a terminal and dnf updating packages.

I’ll have a look around what you mentioned about dbus related issues.

Thanks

One thing you can do is run strace -s 1024 -f firefox 2>&1 | tee log.txt and see what it’s doing during the delay time. It’s going to be very noisy, but you might find a hint there.

Yea I tried that first and it there’s a lot of noise alright.

I am afraid I don’t really know how to interpret the output. I’ve since discovered that this issue is also affecting Thunderbird and that I miscounted, its 4 minutes and not 2 it takes to open.

there are two main points in the strace where the delays are happening. One is a 15 sec delay, there are smaller 5 sec delays but the main one is a of almost 2 full minutes.

The logs jump from 09:39:50 to 09:41:45 waiting for 1 minute 55 seconds.

Not expecting you to debug them or anything, just adding them here in case others have same issue and comes across this

[pid  4767] 09:39:50 rt_sigprocmask(SIG_BLOCK, [HUP USR1 USR2 PIPE ALRM CHLD TSTP URG VTALRM PROF WINCH IO],  <unfinished ...>
[pid  4791] 09:39:50 recvmsg(10,  <unfinished ...>
[pid  4767] 09:39:50 <... rt_sigprocmask resumed>[], 8) = 0
[pid  4791] 09:39:50 <... recvmsg resumed>{msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="l\2\1\1\0\0\0\0\377\377\377\377>\0\0\0", iov_len=16}], msg_iovlen=1, msg_controllen=0, msg_flags=MSG_CMSG_CLOEXEC}, MSG_CMSG_CLOEXEC) = 16
[pid  4767] 09:39:50 socket(AF_UNIX, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, 0 <unfinished ...>
[pid  4791] 09:39:50 ppoll([{fd=9, events=POLLIN}, {fd=11, events=POLLIN}], 2, {tv_sec=0, tv_nsec=0}, NULL, 0) = 0 (Timeout)
[pid  4791] 09:39:50 ppoll([{fd=10, events=POLLIN}], 1, {tv_sec=0, tv_nsec=0}, NULL, 0 <unfinished ...>
[pid  4767] 09:39:50 <... socket resumed>) = 17
[pid  4791] 09:39:50 <... ppoll resumed>) = 1 ([{fd=10, revents=POLLIN}], left {tv_sec=0, tv_nsec=0})
[pid  4767] 09:39:50 connect(17, {sa_family=AF_UNIX, sun_path="/run/systemd/resolve/io.systemd.Resolve"}, 42 <unfinished ...>
[pid  4791] 09:39:50 recvmsg(10,  <unfinished ...>
[pid  4767] 09:39:50 <... connect resumed>) = 0
[pid  4791] 09:39:50 <... recvmsg resumed>{msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="\5\1u\0\27\0\0\0\7\1s\0\24\0\0\0org.freedesktop.DBus\0\0\0\0\6\1s\0\6\0\0\0:1.143\0\0\10\1g\0\0\0\0\0", iov_len=64}], msg_iovlen=1, msg_controllen=0, msg_flags=MSG_CMSG_CLOEXEC}, MSG_CMSG_CLOEXEC) = 64
[pid  4767] 09:39:50 sendto(17, "{\"method\":\"io.systemd.Resolve.ResolveHostname\",\"parameters\":{\"name\":\"VFIEVOX3\",\"family\":2,\"flags\":0}}\0", 102, MSG_DONTWAIT|MSG_NOSIGNAL, NULL, 0 <unfinished ...>
[pid  4791] 09:39:50 ppoll([{fd=9, events=POLLIN}, {fd=11, events=POLLIN}], 2, {tv_sec=0, tv_nsec=0}, NULL, 0 <unfinished ...>
[pid  4767] 09:39:50 <... sendto resumed>) = 102
[pid  4791] 09:39:50 <... ppoll resumed>) = 0 (Timeout)
[pid  4767] 09:39:50 recvfrom(17,  <unfinished ...>
[pid  4791] 09:39:50 ppoll([{fd=10, events=POLLIN}], 1, {tv_sec=0, tv_nsec=0}, NULL, 0) = 0 (Timeout)
[pid  4791] 09:39:50 write(11, "\1\0\0\0\0\0\0\0", 8 <unfinished ...>
[pid  4767] 09:39:50 <... recvfrom resumed>0xaaaba00d7840, 131080, MSG_DONTWAIT, NULL, NULL) = -1 EAGAIN (Resource temporarily unavailable)
[pid  4791] 09:39:50 <... write resumed>) = 8
[pid  4767] 09:39:50 ppoll([{fd=17, events=POLLIN}], 1, {tv_sec=119, tv_nsec=999792000}, NULL, 8 <unfinished ...>
[pid  4791] 09:39:50 ppoll([{fd=9, events=POLLIN}, {fd=10, events=POLLIN}, {fd=11, events=POLLIN}], 3, NULL, NULL, 0) = 1 ([{fd=11, revents=POLLIN}])
[pid  4791] 09:39:50 read(11, "\1\0\0\0\0\0\0\0", 8) = 8
[pid  4791] 09:39:50 ppoll([{fd=9, events=POLLIN}, {fd=10, events=POLLIN}, {fd=11, events=POLLIN}], 3, NULL, NULL, 0 <unfinished ...>
[pid  4767] 09:41:45 <... ppoll resumed>) = 1 ([{fd=17, revents=POLLIN}], left {tv_sec=4, tv_nsec=735486089})
[pid  4767] 09:41:45 recvfrom(17, "{\"parameters\":{\"addresses\":[{\"ifindex\":2,\"family\":2,\"address\":[192,168,1,12]}],\"name\":\"VFIEVOX3\",\"flags\":786945}}\0", 131080, MSG_DONTWAIT, NULL, NULL) = 114
[pid  4767] 09:41:45 rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
[pid  4767] 09:41:45 close(17)          = 0
[pid  4767] 09:41:45 getpid()           = 4767
[pid  4767] 09:41:45 symlinkat("192.168.1.12:+4767", AT_FDCWD, "/home/silas/.mozilla/firefox/lcpxt1ts.Silas/lock") = 0
[pid  4767] 09:41:45 openat(AT_FDCWD, "/home/silas/.mozilla/firefox/lcpxt1ts.Silas/compatibility.ini", O_RDONLY) = 17
[pid  4767] 09:41:45 newfstatat(17, "", {st_mode=S_IFREG|0600, st_size=168, ...}, AT_EMPTY_PATH) = 0
[pid  4767] 09:41:45 read(17, "[Compatibility]\nLastVersion=120.0.1_20231201093502/20231201093502\nLastOSABI=Linux_aarch64-gcc3\nLastPlatformDir=/usr/lib64/firefox\nLastAppDir=/usr/lib64/firefox/browser\n", 168) = 168
[pid  4767] 09:41:45 close(17)          = 0```

Have you checked DNS, e.g., systemd-resolve --status?

Looks like it’s trying to resolve a machine called VFIEVOX3, and that’s what is taking so long. Any idea what that is?

VFIEVOX3 is the hostname of the machine itself. Except, seems it only knows itself by the name VFIEVOX3.Router which resolved what looks like an IPv6.

I added the name to /etc/hosts as 127.0.0.1 and lo and behold - the issue is resolved!

I checked this and it looked OK. But I don’t understand how it stopped resolving its own name

Interesting. I have the local hostname in /etc/hosts on some machines (as 127.0.1.1), but not all of them. In particular, I suspect this is set by the Calamares install flow somehow (I have it on all my laptops but not the server machines, not even the most recent installs the other day).

I would assume the machine was trying to resolve itself against your configured DNS server, and that was failing/timing out. But honestly all this name resolving stuff is quite deep and convoluted, so I have no idea what the real root cause would be.

Either way, I am grateful for your insight… Solved the problem and taught me a bit about straces! Asahi saved my M1 air from being sold, went from sitting on a desk for a year to my daily driver so I am glad to have browsers back on it…