Fullscreen apps/games not opening on primary display

I have two displays, a 1080@144 and a 4k@60. I prefer the 144 hz display for playing games on, and also launching fullscreen apps I’m developing so I can keep my editor/debugger/whatnot on the high-res display. To force that in F37 (or other distros), I set my 144 hz display to be the primary display in Gnome Settings. In F38 it always defaults to placing them on my (non-primary) 4k display. In many SDL based games, it’s impossible to run them fullscreen on my 144 hz display, as setting them to fullscreen always picks my (non-primary) 4k display instead.

The only workaround I’ve found is to set SDL_VIDEODRIVER=x11 as XWayland seems to pick the correct display, but it only works for SDL games. I’m aware that Fedora forces Wayland for SDL games. There used to be a few SDL/Wayland issues with games, but overall I wasn’t bothered by it. Since launching fullscreen is the default for most games, this now breaks nearly all games. :frowning: Unsure where to file this bug though. It doesn’t seem to be an SDL bug as I tested the latest release from source on both F37 and F38. Could this be a Mutter regression or is it something that changed in Wayland?

Please have a look also in gnomes discourse:

In case anyone else runs into the issue, I did find a workaround: I backed up my .config/monitors.xml file, reconfigured displays in Gnome Settings and rebooted. Now everything works as expected. The new file had reordered elements, but otherwise no changes.

Seems to be a Mutter bug so I filed it with more info there? Wayland fullscreen windows open on secondary display (#2784) · Issues · GNOME / mutter · GitLab