Fresh install of Silverblue

Hello, I’ve tried running a fresh install of Fedora Silverblue 36 by doing the following:
1.) downloaded the Fedora SB ISO from the website
2.) Used Fedora Media Writer to create the bootable disk
3.) Restarted my comptuer

The first time I did that, my computer showed me something about what was on the Sandisk 64 gb flash drive, which is Fedora Silverblue, said something about a shadow then the only option was to hit esc. to exit


Second time, it booted up and gave me the option of Fedora 34 or the Fedora 36 that I had upgraded to.

Two things at this point
1.) I did just upgrde to Fedora 36, so the listed versions of Fedora Sivlerblue in this menu made sense by having a couple w/ Fedora 34 and a couple with Fedora 36 - but this is obviously not the fresh install menu I was looking for
2.) I had added some difft. theme customizations based on a video I watched of someone making their GUI for Gnome look better, it seemed to work at first but then the icons get all messed up, things are shifted around and blah blah for the OS don’t function. I literally can’t search for software and at this juncture, I’ve reinstalled this OS so many times at this point that I might as well just start fro scratch again.

I like how one can roll back with Silverblue, and I need to get used to containers anyways, plus a numbe rof other things which is why I like silverblue. I do NOT like Silverblue because when I use Gnome Boxes on the system, it won’t recognize my flash drives anymore because the Flatpak doesn’t support that type of sharing.

All that to say, I have a Lenovo ThinkPad Carbon X1 Gen 8 and the hard drive is encrypted* I’m assuming this is why this particular re-install/fresh install is giving me a bit more trouble.
Any advise on how to use Virtual Machines with Silverblue would be great, because the container for Gnome Boxes isn’t great either; Sivlerblue doesn’t support VMWare; CoreOS seems like ti would’ve been absolutely perfect, but too late to the game so that’s out of the equation; from what I hear, Rocky Linux is mainly to beused solely as a Server based Linux distro, otherwise uses Gnome 3. If I use WorkStation, I’ll break it 10x more than Silverblue, so the compromise is working with a system that works against me but at least I can roll back = Silverblue.

any help on how to get this thing up and running with a fresh install w/ the above computer info. and fact that it’s encrypted at the hard drive would be fantastic. Someone had given me these instructions for WorkStation before, but I don’t tink the hard drive was encrypted at that point - so I’m just trying to figure out if anyone has any instructinos on what might be done here.

I’ve layered gnome-boxes in the past and it’s been fine, especially if you can’t work around getting the USB thing working. rpm-ostree install gnome-boxes will pull in everything you need.

As far as the drive encryption goes are the other OSes on the disk that you’re trying to integrate with? I selected the encryption option on install, gave it a password and then it does it’s thing, it just blows away the disk and sets it up from scratch.

1 Like

Yeah I shouldn’t have said I do not like Silverblue for this reason, more along the lines of Flatpak and Gnome I suppose. That said, I have ran rpm-ostree install gnome-boxes on Fedora 33 Silverblue (I think it was) and that worked just fine actually. I was told to either use containers or flatpaks the next time around though, so with this past one, I used Flatpak and didn’t find out that I couldn’t access thumb drives or anything like that until I already have all of my .pem keys set up with cloud infra’s running. Another challenge is that I actually use Ubuntu for when I’m spinning up cloud servers because it’s one of the only systems that had A-Z training for what I was aiming to accomplish at that time ha. Now I’m coming up against getting Kubernetes w/ Minikube up and running on Silverblue → mainly off of these pages:

Well at any rate - I think I’ll get blocked for posting anymore about that as it wasn’t related to the original issue. Back to the issue at hand and to answer your question: no, I don’t have this partitioned/there aren’t any other OSes on this machine outside of Gnome Boxes (I don’t think you were asking about VMs). I just downloaded the Fedora Silverblue ISO, used Fedora Media Writer to get in on a Sandisk and tried to boot up. I do believe, however, that I hit F2 on this last try, when I’m looking into it more and I think it just is meant to go right into the install menu…? Well, I did re-write the Sandisk w/ Fedora Media Writer and didn’t hit anything as it booted the 2nd time and no luck. I’m actually going to give it another shot right now by writing the thumb drive w/ BalenaEtcher on a MacBook. We’ll see - fingers crossed. Thanks for the response.

1 Like

Well, it worked! I have Gnome-Boxes that now shares the public directory with the main SB-OS, so now I guess I can figure out Kubernetes+Minikube. Thanks, Jorge.

1 Like

It actually now just keeps randomly shutting down. All of the sudden, it just closes out. Any ideas as to why?