Fractional Scaling on X11

Greetings,

Is there a reason why I can’t enable fractional scaling when running an X11 session? I can only do so by starting a Wayland session. Unfortunately, I can’t use Wayland because it’s unusable on my machine.

It’s been the case since Fedora 39.
Thanks for your help.

Added x11 and removed wayland

I expect that there is no code written to do the scaling for X11, or its not practical on X11 design.

It wasn’t the case when I tried on Ubuntu 23.10 last time. I’m not feeling blasting my sweet Fedora install. I tried Ubuntu 24.04LTS to run a X11 session in a VM, and it doesn’t pass GDM, crashing all the time.

Please explain, specifics.

I wrote this piece in a different topic:

FWICG, Fractional scaling is in X11 on KDE. You didn’t mention it so I assume you are on Fedora Workstation Gnome, There are issues with it but to set it up you need to do some fiddling.

HiDPI (Fractional scaling) gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

It is experimental so good luck. . .

Yeah that command line only works on Wayland unfortunately.