Forbidden base package replacements issue due to glibc 2.30

On my Fedora 31, issue when running rpm-ostree upgrade.

% rpm-ostree status
State: idle
AutomaticUpdates: disabled
Deployments:
ā— ostree://fedora:fedora/31/x86_64/silverblue
                   Version: 31.20200109.0 (2020-01-09T00:43:29Z)
                BaseCommit: b0790118b35fba1a35bd2c2cfa7db4ab235fa6561ad9fda1a4cda0111a8e1914
              GPGSignature: Valid signature by 7D22D5867F2A4236474BF7B850CB390B3C3359C4
           LayeredPackages: ImageMagick R R-R.cache R-R.utils R-callr R-littler R-prettydoc R-rmarkdown aide alacarte android-tools apg
                            byacc chromium dnf electrum fedora-workstation-repositories flex gcc 'gcc-c++' git gnome-font-viewer
                            gnome-tweak-tool httpie hugo kubernetes-client lapack libappindicator libnss3.so libvirt mako mutt nano nc
                            ncdu nmap nodejs openblas perl-AnyEvent-I3 perl-open python3-kobo-rpmlib qemu rofi scratch seahorse
                            setroubleshoot snapd sway syslinux-nonlinux telnet thunderbird unar vim virt-install virt-manager wmctrl
                            yarn zsh
             LocalPackages: rstudio-1.2.1565-1.x86_64

  ostree://fedora:fedora/31/x86_64/silverblue
                   Version: 31.20200109.0 (2020-01-09T00:43:29Z)
                BaseCommit: b0790118b35fba1a35bd2c2cfa7db4ab235fa6561ad9fda1a4cda0111a8e1914
              GPGSignature: Valid signature by 7D22D5867F2A4236474BF7B850CB390B3C3359C4
           LayeredPackages: ImageMagick R R-R.cache R-R.utils R-callr R-littler R-prettydoc R-rmarkdown aide alacarte android-tools apg
                            byacc chromium dnf electrum fedora-workstation-repositories flex gcc 'gcc-c++' git gnome-font-viewer
                            gnome-tweak-tool httpie hugo kubernetes-client lapack libappindicator libnss3.so libvirt mako mutt nano nc
                            ncdu nmap nodejs nodejs-yarn openblas perl-AnyEvent-I3 perl-open python3-kobo-rpmlib qemu rofi scratch
                            seahorse setroubleshoot snapd sway syslinux-nonlinux telnet thunderbird unar vim virt-install virt-manager
                            wmctrl zsh
             LocalPackages: rstudio-1.2.1565-1.x86_64
#  rpm-ostree upgrade   
1 metadata, 0 content objects fetched; 569 B transferred in 1 seconds
Checking out tree 65f73f4... done
Enabled rpm-md repositories: updates fedora copr:copr.fedorainfracloud.org:shengis:mako yarn
Updating metadata for 'updates'... done
rpm-md repo 'updates'; generated: 2020-01-20T01:24:49Z
Updating metadata for 'fedora'... done
rpm-md repo 'fedora'; generated: 2019-10-23T22:52:47Z
Updating metadata for 'copr:copr.fedorainfracloud.org:shengis:mako'... done
rpm-md repo 'copr:copr.fedorainfracloud.org:shengis:mako'; generated: 2019-02-05T10:47:11Z
Updating metadata for 'yarn'... done
rpm-md repo 'yarn'; generated: 2019-12-11T13:30:17Z
Importing rpm-md... done
ā   
Forbidden base package replacements:
  glibc-devel 2.30-10.fc31 -> 2.30-8.fc31 (updates)
  glibc 2.30-10.fc31 -> 2.30-8.fc31 (updates)
  glibc-headers 2.30-10.fc31 -> 2.30-8.fc31 (updates)
  glibc-all-langpacks 2.30-10.fc31 -> 2.30-8.fc31 (updates)
  glibc-common 2.30-10.fc31 -> 2.30-8.fc31 (updates)
This likely means that some of your layered packages have requirements on newer or older versions of some base packages. Doing `rpm-ostrResolving dependencies... done
error: Some base packages would be replaced

I already ran rpm-ostree cleanup -m , but no success.

Thank you for help

Hmm, weird. I think somehow glibc-devel-2.30-10.fc31 was included in the Silverblue compose before it was actually pushed to stable: https://bodhi.fedoraproject.org/updates/FEDORA-2020-1a3bdfde17. Not sure what happened there.

Anyway, this should resolve itself once the glibc update is pushed.

Yes indeed. I was able to update today. Some patience was needed, nothing else.

1 Like