Flatpak HDMI Pulseaudio not working only for some programs

System76 Meerkat
Fedora Silverblue 34
Pipewire pulseaudio over HDMI
Flatpak (The Application is Stepmania)

Most flatpaks on this system have working audio (Shortwave, Firefox, some games) but after a few updates ago I didn’t notice that Stepmania stopped working. Stepmania hasn’t been updated in quite some time, and it works on other computers I have, so I am narrowing this down to pipewire/pulsaudio.

journalctl output

 pipewire[1192]: (alsa_output.pci-0000_00_1f.3.hdmi-stereo-38) XRun! rate:256/48000 count:1 time:80475012 delay:1503408 max:1503408
 gsd-media-keys[1341]: Unable to get default sink
 pipewire-media-session[1228]: no node found for 49
 pipewire-pulse[1193]: stream 0x5591e367feb0: error no node available
 pipewire-pulse[1193]: pulse-server 0x5591e3698b20: [StepMania] ERROR command:-1 (invalid) tag:4294967295 error:25 (Input/output error)

Maybe you need to set the default ALSA device? Just as an example, I have the following in /etc/asound.conf.

pcm.!default {
	type asym
	playback.pcm "hdmi:CARD=HDMI,DEV=0"
	capture.pcm "plug:rnnoise"

You probably would need to change hdmi:CARD=HDMI,DEV=0 to whatever device string your system uses. You should be able to list your ALSA devices with the following:

$ aplay -L

My current default with aplay -L shows Default ALSA output (currently PipeWire Media Server)

Just s note, most other audio works. It is just this flatpak application and a similar application in toolbox. But otherwise audio is working.

updated main post with a more relevant log.

What’s weird is that some stuff works.
Shortwave (flatpak) works just fine (Radio streaming application).
Firefox (flatpak) can stream videos with audio just fine.

Stepmania not :thinking:

If I have Gnome Control Center open on the Sound bad then launch Stepmania (leaving settings open on sound) then audio in Stepmania works as expected. But if close settings and relaunch Stepmania with settings closed, no audio…

Another funny thing is if I put Stepmania in undecorated maximized window instead of Fullscreen then audio seems to work haha…

So… seriously weird stuff.

If Pipewire is too buggy for whatever reason. You can try “downgrading” back to pulseaudio with the following command.

$ sudo dnf swap --allowerasing pipewire-pulseaudio pulseaudio
1 Like

I could (using the Silverblue equivalent). But I’d hate to do that for just one application :sweat_smile: