Firefox audio codec support

Found out that there is no support for flac, vorbis and other codecs.

All recommendations have been implemented

Also installed ffmpeg and ffmpeg-libs from RPMFusion.
Also installed mesa-vdpau-drivers-freeworld and mesa-va-drivers-freeworld

I think I saw your post on Reddit as well. What I did was install ffmpeg-free from rpmfusion-free. I know you commented there that you did that as well. I can’t remember what type of video card you have, but I have an Intel card and had to do the following:

Hardware Accelerated Codec

Intel(recent)

Using the rpmfusion-nonfree section

sudo dnf install intel-media-driver

or Intel(older)

Using the rpmfusion-free section

sudo dnf install libva-intel-driver

Taken from: https://forums.fedoraforum.org/showthread.php?330144-Playing-videos-in-Firefox-in-Fedora-38

Hope this helps!

The intel-media-driver package for hardware support for Intel GPU video codecs.

Name         : intel-media-driver
Version      : 23.4.3
Release      : 1.fc39
Architecture : x86_64
Size         : 35 M
Source       : intel-media-driver-23.4.3-1.fc39.src.rpm
Repository   : @System
From repo    : rpmfusion-nonfree-updates
Summary      : The Intel Media Driver for VAAPI
URL          : https://github.com/intel/media-driver
License      : MIT and BSD
Description  : The Intel Media Driver for VAAPI is a new VA-API (Video Acceleration API)
             : user mode driver supporting hardware accelerated decoding, encoding,
             : and video post processing for GEN based graphics hardware.
             : https://01.org/intel-media-for-linux

Thank you all and I apologize, it’s not the codecs, it’s the firefox configuration. After resetting the settings to default everything is ok.

1 Like