Firefox 72.0.1 does not properly render web pages that contain javascript

On Fedora 31, firefox 72.0.1 does not render pages that contain javascript. The degree of rendering depends on the structure of the pages … however for most pages (,, for example), the firefox 72.0.1 does nothing at all … not even an error. It acts like it has downloaded something, but nothing changes in the browser window.

I found a page that did not contain any javascript and it loaded satisfactorily.

I downgraded firefox to 69.0.1 and firefox loaded all pages satisfactorily.

Has anyone else observed what appears to be a difficulty with the firefox 72.0.1 fc31 package?

I used dnf to both upgrade and downgrade the firefox packge.

No, it’s working fine for me.

Did you try restarting the browser in safe mode (Help → Restart with Add-ons disabled) to rule out some add-on issue?

Maybe check the Web Developer Console for hints of what could be wrong?

Thank you, @fasulia.

I restarted firefox 72.0.1 in safe mode (add-on disabled) and an attempt to access produced the same result: page did not render, no error, no change to the browser window.

developer tools > network showed one action:
GET / document 0 B transferred 0b size

This contrasted with an attempt via firefox 69.0.1. When it accessed, page rendered successfully and developer tools > network reported:
GET / document html xfer cached size 74.98 KB 482 ms
GET " wikipedia-logo-v2.png imageset png xfer 15.46 KB size 15.46 KB
GET " index-c1cb7f1287.js script js xfer 8.91 KB size 24.77 KB
GET " gt-ie9-a2995951ca.js script js xfer 643 B size 643 B
GET: " sprite-81a290a5.svg img svg xfer 16.71 KB size 41.70 KB
GET " Wikinews-logo_sister.png img png xfer 2.02 KB size 2.02 KB
GET " wikipedia.png img img png xfer 1.37 KB size 1.37 KB
GET " wikipedia.ico img vnd.micro xfer 1.01 KB size 2.67 KB

Additional note: when firefox 72.0.1 attempted to access,
the status column of the developer tools > network report was blank.

Normally, the status of the first GET ( shows a return status 304. (At least for my attempts today with an earlier version of firefox).

This means not modified, or cached.

Try clearing browser cache.

1 Like

I cleared browser cache and cookies and clear history (time range: everything). does not render.

But firefox v69 still works?

Yes, the pages render with v 69.


Try removing/reinstalling firefox? Try the same webpages with other browsers like chromium?

Hopefully others can provide better diagnostics.

Yes, I have removed and reinstalled. However, hoping that the third time would be the charm, I did the following:

First, moved my ~/.mozilla and ~/.cache/mozilla
Second, sudo dnf remove firefox
Third, sudo dnf install firefox

[07:58:08]$ date ; sudo dnf install firefox ; date
Tue 14 Jan 2020 07:59:18 AM EST
Last metadata expiration check: 0:57:53 ago on Tue 14 Jan 2020 07:01:26 AM EST.
Dependencies resolved.
 Package                 Architecture Version               Repository     Size
 firefox                 x86_64       72.0.1-1.fc31         updates        98 M
Installing dependencies:
 u2f-hidraw-policy       x86_64       1.0.2-10.fc31         fedora         22 k

Transaction Summary
Install  2 Packages

Total download size: 98 M
Installed size: 226 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): u2f-hidraw-policy-1.0.2-10.fc31.x86_64.r  80 kB/s |  22 kB     00:00    
(2/2): firefox-72.0.1-1.fc31.x86_64.rpm         2.7 MB/s |  98 MB     00:35    
Total                                           2.6 MB/s |  98 MB     00:37     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Running scriptlet: firefox-72.0.1-1.fc31.x86_64                           1/1 
  Preparing        :                                                        1/1 
  Installing       : u2f-hidraw-policy-1.0.2-10.fc31.x86_64                 1/2 
  Installing       : firefox-72.0.1-1.fc31.x86_64                           2/2 
  Running scriptlet: firefox-72.0.1-1.fc31.x86_64                           2/2 
  Verifying        : firefox-72.0.1-1.fc31.x86_64                           1/2 
  Verifying        : u2f-hidraw-policy-1.0.2-10.fc31.x86_64                 2/2 

  firefox-72.0.1-1.fc31.x86_64      u2f-hidraw-policy-1.0.2-10.fc31.x86_64     

Tue 14 Jan 2020 08:00:07 AM EST

Launched firefox 72.0.1 fc31. The welcome / intro page displayed. I clicked start browsing (google search) … no change, no google search page.

Here is another diagnostic step: I accessed a simple, local file that contained one javascript (from Freeman & Robson’s Head First javascript programming:

<!doctype html>
<html lang="en">
    <meta charset="utf-8">
    <title>Just a generic page</title>
      function wakeUpUser() {
      alert("Are you going to stare at this boring page forever?");
    <h1>Just a generic heading</h1>
    <p>Not a lot to read about here. I'm just an obligatory paragraph living in an example in a JavaScript book. I'm looking for something to make my life more exciting.</p>

firefox 72.0.1 fc31 handled this file SUCCESSFULLY. So the firefox javascript engine appeared to be operational.

Another observation: firefox 72.0.1 Help > Preferences > General Applications shows only (4) types:

portable document format (PDF)

On my functional firefox browser (downgraded version) the Application table shows many more, including JSON file.

As for chrome on fc31, it runs fine for me. chrome-79.0.3945.88. I just prefer to use firefox for most browsing.

With the newer firefox: Did your tried to run it from the terminal emulator? Maybe it will show some errors.

Since you are doing many tests, you could also try to create a brand new system user, and log in with it.
In this way you can know if the issue is system wide or limited to a single user.

Thanks for the replies, @vits95 and @alciregi.

I have not yet installed a terminal emulator.

I added another user, and that user experienced the same problem: web pages do not render.

The pattern:
all https pages do not render.
http requests succeed.

I monitored an https request with wireshark: (wikipedia) TLS 1.2 Server Hello handshake
my host sent TCP ack.
then my host sent a TLS 1.2 fatal alert: Bad Certificate

It never established a TLS 1.2 connection.

So I will probably close this thread and start a new thread with an appropriate title.

My apologies for posting with an incorrect title – the classic sys-admin-in-a-hurry-making-inferences-based-on-insufficient-information syndrome! :roll_eyes:

1 Like

Hi mjmolnar74,
Have you checked that your nss and nspr packages are up to date?
See the reference here:
You can check ‘Library Versions’ in about:support to see if they’re the minimum firefox requires.
SInce your http requests succeed but not your https, this might well be the problem.


Thank you, @jonathans ! Your diagnose was on the mark – about:support indicated nspr and nss were one rev behind:

nspr was 4.23, firefox expected 4.24
nss was 3.47.1, firefox expected 3.48

After updating nss (dnf upgrade nss), firefox (72.0.1) renders the https web pages. The single dnf upgrade of nss upgraded the entire set: nspr, nss, nss-softokn, -sysint, -util.

Arch Linux motto:Never do a partial updates”.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.