Feedback regarding small problems after installing Fedora Asahi Remix 39

this is a sum of the little points i could note after installing and testing fedora39 for a few days, from user perspective. despite the few issues i list below, the overall experience is not bad at all. it feels stable and responsive.

  • no APFS support in kernel

i noticed kernel didn’t have support for apfs filesystem. it’s a bit too bad since it would be convenient to have and linux does support it. could the maintainer consider adding it ? i tried it before and if i remember correctly it worked well enough to copy over some files from mac partitions and external drive i had formated with apfs, to linux side. (as long as they’re not encrypted). and also as second choice: there’s fuse-apfs available in repo but it refused to work.

  • keymap problems

in TTY it’s badly broken. it will work with some keys, but suddenly it will start to write garbage for some time, then it will go back working, then start to write garbage again, all this in a loop. for me it start to go bad when pressing some combo keys like option+rightshift+l (opt+shift+L) it’s supposed to input the pipe symbol “|”. but that is just an example, it breaks with other keys, and other combos too. (my keymap is “fr-mac”). also to note: this even when it is in working state, the keys “< / >” and “@ / #” are switched. And also, in TTY, when keyboard start to behave badly, i cannot go back to graphical session (ctrl+alt+f2). finaly, while in wayland, the keyboard is a lot more reliable, but there is still this switched keys problem.

  • BT audio

when i use my airpod pro, the audio keep on switching to some bad quality output and good quality output. it’s like if it’s switching audio profile on a loop. so listening to anything at all is not that a great experience. i also noticed that sometimes the mac will try and connect to the airpod while i’m not touching them, they are in their case and for some reason the mac connect to them then disconnect them all on its own, without me doing anything.

  • TTY font too small

we all have hidpi screen on our macbooks. both uboot and TTY have too small font by default. it would be nice to have something bigger. i did set mine to FONT=latarcyrheb-sun32 in /etc/vconsole.conf.

  • false power-off

normaly, when the macbook is really powered off, the trackpad cannot be pressed. it doesn’t register a click, it’s like a brick until mac gets powered on. only then it can be pressed and register a click. with asahi / fedora39, when i shutdown the mac, it looks like it’s powered off, but it is not really so. i can press trackpad, and it will register a click, and when i do that, it triggers a boot of the system. only way to really power the system off is keep power key pressed while mac is booting, hopefully before uboot finishes.

  • mpv has issues

while seeking forward and backward, the whole movie freeze, or start to go off sync between image and audio. mpv is my favourite audio and video player specificaly because it is lightweight and fast, and it never done this before either on linux or mac, it always worked flawlessly. but on asahi it doesn’t work as expected. seeking in audio and video is broken.

  • keymap doesn’t get applied properly at install time.

in the install UI, i was offered to select a keymap, but it never gets applied no matter what i choose. i had to fix that manualy after install finished.

  • macbook runs a bit hotter

a tad hotter than macos. i have no idea why. i can only guess. maybe it’s because mac is always running at max resolution, while macos runs at lower resolution by default ? i have no idea. it’s not running very hot, it’s just warm (lightly so). but in macos it runs cold, in comparison.

  • wifi signal seems lower

although i had no connectivity issue at all so far, the wifi signal seems to be received with less strength than on macos. the laptop on my desktop, at same place, macos find the same wifi and display more reception bars than linux. (on linux it fluctuate from zero bars to one bar, while on macos it stays at two bars all the time).

  • deepin desktop doesn’t render correctly.

i use kde normaly, but i wanted to test out deepin DE, it started but wasn’t really usable, a few panels rendered as blurred blanks. and the fullscreen menu to start apps also have problem, the mouse leaves an unrefreshed track behind its passage.

1 Like

Thanks for the report. It is very helpful, as what can be “little” problems for you could be blockers for others.

I don’t think the relationship between bars and signal strength is consistent across platforms. For each platform you have to figure out how many bars are needed for a reliable connection.

you are correct, that was a bit too vague, sorry about that. i’ll have to reboot to macos and install wavemon using homebrew (i hope they package it). so i can properly compare.

meanwhile, for what it’s worth, on fedora i have:
link quality: 43%
signal level: -80dbm
tx power: 31 dBm (1258,93 mW), power save: on

it’s on a 5Ghz wifi connection. hardware is a m2pro, macbook pro 14" (2023).

rebooted on macos briefly, and unfortunately wavemon isn’t packaged by either homebrew or macports. i could gather a bit of info though:
rssi: -81 dBm
noise: -93 dBm
if i’m reading this correctly, signal quality is about the same on macos and linux then ?

There is no suitable apfs driver and access to the macOS user data requires SEP (secure enclave processor) support since the user is encrypted.

Can’t compare the bars if there are issues with transmitting data from the macbook [brcmfmac] Fix regulatory domain handling to reset bands properly by dberlin · Pull Request #220 · AsahiLinux/linux · GitHub might increase the transmit power (depends on your area’s wifi regulation).

thank you for the link, i’ll check it out. i’ll also reboot to macos in a moment, to test wavemon (if it’s packaged by homebrew or macport), and i’ll update my post above.

i have a question regarding keymap, if i modify located at: /usr/lib/kbd/keymaps/xkb/ to manualy swap keys 86 and 41 ( “<>” and “@#”) then gzip it again and put it back at same place, would that work ? ( using localectl set-kmap fr-mac ) or is it something else in wayland ? and for tty ?

That’s a normal power-off. The same exact thing happens on macOS when you do a controlled shutdown. The machine really is off, it’s just designed to power up on trackpad click like that. It’s the forced power down state you triggered with the power button prior to Linux that is abnormal, and breaks that functionality. This is all working as intended.

that’s a good news then. thank you for pointing it. i’ll avoid forcing hard shutdown (keeping power button pressed) from now on.

i’ll try it of course next time i’ll have to reboot on macos, but if you say so i guess it will be like you said. to justify what i reported: i remember a few years back when apple introduced that haptic feedback trackpad, i told a friend about it, i told him: “based on what i’ve read, if you power down the machine, the trackpad shouldn’t register clicks anymore and behave like a brick instead” we tested it on his machine and it was so. but apple may have changed that behavior meanwhile. and so it is entirely possible i made a few bad observations. if that’s the case, then i’m sorry for that oversight.

so, wifi signal is on par with macos,
proper shutdown is also on par with macos,
that’s two points off my list. good to know, thanks again for the correction.

about apfs support though, i remember having mounted and accessed apfs drives from linux before. maybe @jannau is correct there too, and all i did was accessing external drives and not the internal one ? but even so, it would still be handy to have apfs support in the kernel. even if it’s just in read only mode.

to sum it up,
from my point of view on what i could notice so far,
what’s left are the keymap problems, mpv seeking issue and bt audio too.

Hey @freeeaks , did you manage to fix your mpv issues? I’m experiencing similar issues (freezes when seeking) on top of bad performance. I have recently moved from arch asahi to fedora asahi and it all worked well on arch, the performance “by default” is okay but when I add things like profile=gpu-hq or use glsl shaders (real-time upscaler) the video gets extremely choppy.

I think it happened for both of guys because profile=gpu-hq parameter. I am not sure though. Maybe it needed some feature that is not supported yet in the asahi-gpu driver. Can you disable it and try the seeking thing again and report your findings?

Can’t reproduce the freezes today regardless of my mpv.conf, it could maybe be related to using bluetooth speaker in conjuction with high cpu usage (some background stuff running)? I saw some orange text av desync/high cpu load warning in mpv output when it happened. The bigger problem for me is the performance of glsl shaders (low end-gpu variation), they did not drop frames on arch but they do on fedora with exactly same config (copied dotfiles).