Fedora38 Public key for brave-browser

I thought this problem was resolved, but not so sure. I tried to do the latest refresh including Brave-Browser and the “Public key for brave-browser not installed.” Try downgrading the Brave, ([FAILED] brave-browser-1.52.129-1.x86_64.rpm: No more mirrors to try - All mirrors were already tried without success)

Whats the current procedure to get the brave-browser public key installed?

sudo rpm --import https://brave-browser-rpm-release.s3.brave.com/brave-core.asc

Installing Brave on Linux | Brave

Install brave as flatpak
Without touching the core system

Or maybe as snap

What’s the difference between Brave and Firefox?

A bunch. better to read thier web page - https://brave.com/

Brave is base on chromium project and use blink engine.
Firefox is gekco.
And most people prefer brave over firefox because brave is private out of the box they enable ad blocker tracker blocker so on and also use a different search engine like brave search but firefox does not have this this stuff you need to enable or customized by the user.
So for privacy concern users it is easy to use brave for a better out of the box experience.
Other other hand some people like firefox because they don’t like the monopoly of chromium browser.
And also people like it for many other reasons.

1 Like

Thank you for explaining!