Fedora34 Gnome 40 on X semi freezing

Hello Fedora Community,
I’m a semi experienced linux user and I can’t figure out why my system has these issues.
The situation:
A few times a day (around 1-3 times) my internet connection (is shown as working in the top bar, but it isn’t (can’t load websites)).
Sometimes I can fix it by unplugging the “LAN cable” and plugging it back in.
If this doesn’t work I tried

sudo NetworkManager restart

The terminal freezes than (no password prompt) and it just stays in this state.
I then tried to open the graphical “System Monitor” to check the running processes.
It opens and I can move the window, but once I click on the resources tab the window freezes and becomes unusable.
This behaviour is reproduceable every time the internet connection is lost. The only thing that fixes it is pressing the power button until the computer shuts off and then restarting. (reboot on the command line freezes aswell).

Once I reboot I get prompted with my LUKS password prompt, then the login for my user, after I enter both passwords the computer turns off like in hibernate (sometimes ~50%) and once I press the power button I’m logged in. Super strange behaviour…

My assumption is this is not a single issue but multiple ones.
I tried finding out more by using

journalctl -n 10 PRIORITY=X

But I don’t really get what the errors are saying nor how to fix them.
Also I don’t know which PRIORITY my issues are related to.
I would like to ask if someone with more experience could guide me through the “finding the source of the error(s)” process. Starting with a/the proper journalctl command(s) to use in this situation.

Thanks in advance.
Greetings footworn :slight_smile:

1 Like

if you remember of the hanging time:
journalctl --since “10 minutes ago”

The above will show all logs from 10 minutes ago up to now.

How can I find out what the correct format is? I tried the following to make sure I know what to do once it happens again.

❯ journalctl --since “10 minutes ago”
Failed to parse timestamp: “10
❯ journalctl --since “17:24”
Failed to parse timestamp: “17:24”
❯ journalctl --since “May 28 17:24:00”
Failed to parse timestamp: “May
❯ journalctl --since “28.05.2021 17:24:00”
Failed to parse timestamp: “28.05.2021
❯ journalctl --since “2021-05-28 17:24:00”
Failed to parse timestamp: “2021-05-28
❯ journalctl --since “2021-28-05 17:24:00”
Failed to parse timestamp: “2021-28-05

On a side note, is there a similar command that does “give me the log of the last 10 min prior to the last boot” that might be the easier solution otherwise I have to wait until it happens again and I don’t know what the trigger is (if there is one).

It is working for me:

$ sudo journalctl  --since "10 minutes ago"
-- Journal begins at Mon 2021-05-17 00:44:19 HKT, ends at Fri 2021-05-28 23:42:13 HKT. --
May 28 23:33:55 amdf rtkit-daemon[840]: Supervising 7 threads of 4 processes of 1 users.
May 28 23:33:55 amdf rtkit-daemon[840]: Supervising 7 threads of 4 processes of 1 users.
May 28 23:33:56 amdf audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=rpm-ostreed comm="systemd" exe="/usr/lib/systemd/systemd" hos>
May 28 23:33:56 amdf systemd[1]: rpm-ostreed.service: Deactivated successfully.
May 28 23:33:56 amdf systemd[1]: rpm-ostreed.service: Consumed 4.297s CPU time.


sudo journalctl -b # current boot session
sudo journalctl -b 1 # previous boot session
sudo journalctl -b 2 # the 2nd last boot session

It worked without the time, and it happened again right after posting my last response.
I piped the output for all of the day into a file and removed anything older than 10mins ago.

Its too long to be pasted here. I’m gonna look for a place where I can upload it and past the link after I found something.

Edit: There you go

I am not sure if there are related to your issue, but I see two obvious issues:

Is acvpnagent somekind of VPN service you are running?

May 28 17:46:52 localhost.localdomain acvpnagent[1815]: Function: GetDNSConfig File: ../../vpn/Common/Utility/linux/DBusNMHelper.cpp Line: 283 Invoked Function: DBusNMHelper::getDNSConfigInternal Return Code: -17235957 (0xFEF9000B) Description: DBUSNMHELPER_ERROR_NO_VALID_CONFIG Unable to get IPv6 DNS config for interface enp0s20f0u1u4

gnome-shell’s Strack trace is likely when your Gnome is freezing. But I am not sure why the Stack traces are produced.

May 28 17:47:10 localhost.localdomain gnome-shell[3568]: == Stack trace for context 0x560e52622150 ==

Not really I have a OPNsense router that handles my VPN connection for all of my network and I can use that connection without problems with all my other devices whilst my computer with fedora is having these issues. I have a cisco anyconncet clinet installed in case I have to connect to my universities network but I haven’t done so in a while and I don’t think its running in the background.
At least “System Monitor” is not giving me any entries for “cisco”,“anyconnect” nor “vpn”.
So I have no idea why this is logged…

gnome-shell’s Strack trace is likely when your Gnome is freezing. But I am not sure why the Stack traces are produced.


According to above, it is Cisco VPN .

So it must be triggered to run somehow, otherwise there should not be log entries.

I uninstalled it, but this shouldn’t be related to my issues they started a few days ago and I have had this installed way longer.

I “tried” installing the elementaryOS desktop a few days ago with

sudo dnf group install ‘pantheon desktop’

I assume this and the following uninstalling of it broke the system.
Also I removed (I forgot the name, some QT5 IDE) maybe I removed too many packages.
The system is fully updated/graded tho.

I am not sure, but I will try to install “Fedora Workstation” again to make sure all packages are there.

I was missing “cheese” and its dependencies. I reinstalled it but I can’t imagine this being the cause.

1 Like

Anyway thanks for your help. I hope this resolved the issue.
I will reply here again if/once the problem occurrs again.
If anyone knows what the cause of the gnome-shell stack trace might be feel free to share :smiley:

1 Like

I think I have finally found a place where I can discuss this issue properly.
I have been using Linux regularly for nearly five years now, most of that time spent using Fedora, except for a brief time from the beginning of 2021 and the release of Fedora 34 when I used Ubuntu 20.04. Before the issue that forced me to switch off Fedora quickly, I never had a single issue with running Fedora (though I stopped upgrading after Fedora 27 and wasn’t thinking about the command line that much).
When I ran Ubuntu I did have periodic freezing at the most random of times, and it frustrated me. I was surprised that when I got Fedora 34, it came back, and so I switched to GNOME on Xorg, and while it was more stable, I still had freezing occur periodically, most often times when the laptop blanked the screen.
Specs of laptop: intel core i7-6500U, 16 GB RAM, and intel integrated graphics. Current Fedora setup uses GNOME 40.1 on Xorg, Kernel 5.12.9 (laptop itself is a Lenovo Yoga 900-13ISK, but I doubt the laptop is the issue since it has been dual booted for years with no issue until 2021)
I do not know what is causing it, and searching around on here and bugzilla is inconclusive, and is leaving me with multiple possible causes, but no firm conclusion. I don’t know what I’m looking for in system logs, and even looking at the logs in the three freezes/crashes that happened this month and what happened during those times hasn’t given me anything I could say “this looks like this process broke, causing the system to freeze”.
Again, I’ve never had issues with Fedora before 2021 (back when I still had Fedora 27) and I begun using Ubuntu 20.04 and now Fedora 34. I feel like this is important to note.
(Apologize for the rant)

Yep I still have the same issue + the network connection that is unrecoverably lost from time to time. I was just to frustrated to keep investigating the issue and have too much stuff to do atm to do anything about it since the computer is still useable most of the time. Also don’t really know what to look for / how to debug this.

I’m on a Dell XPS13 with a i7-8565U and also 16gb of ram, Gnome 40.1.0 on X. I really like having up to date software which is why I swtiched to Fedora in the first place, but the most stable OS I ever encountered out of (Arch, Manjaro, Fedora, Ubuntu, Debian, Mint, PopOS, Kali Linux and elementaryOS) was elementaryOS. I just recently added a intel NUC with proxmox to my homesetup so I will probably switch to elementaryOS 6 once it releases and if I ever need anything with a more recent base I will just install it in a VM on proxmox and remote desktop to it.

OK So I want to give an update on my end.
I had someone troubleshoot what was going on, and they installed Windows Server 2019 to it. It had similar freezing issues there. Turns out, the motherboard was fried.
I am now running Linux on a much newer laptop and a large USB drive with no swapfile (because who needs a swapfile with 16GB of RAM? I never used it) and it’s working with no issue at all.
I’m not saying that’ll be the issue for you, and it likely isn’t. It’s just that it was for me.
I don’t think the freezing upon suspend is related to it either. I think it might be power management related (it goes into a hybrid hibernate/shutdown mode which I don’t know if the Linux Kernel can handle, but Windows Boot Manager can handle). If you know what to look for in your UEFI settings, you can likely change it.