Fedora won’t boot up after update

I recently rebooted fedora and let it update to the newest version while doing so. I left and when I got back and tried to log in, I was presented with the following

I tried using the command line and doing sido dnf update but was presented with this

I hope those images were successfully embedded. I am running an intel NUC and am a complete noob so please forgive me. Does anyone know how to fix this?

Oof, it seems like some of your files got corrupted :frowning: What does this print?

$ rpm -V json-c

Yes, the json library is corrupted. And it’s highly likely that it won’t be just that one. You can run sudo rpm -Va to check all RPMs, and you want to look at those which have 5 in the output (checksum differs), and which are not just config files or some other variable files. If many files are affected, it might be easier to reinstall the system than to fix it (your user data can still be backed up, e.g. to flash drive). And it would be good to know why the corruption occurred, the disk might be failing, a cpu or memory failing, etc. It would be good to run some tests, and inspect journalctl.

If it is just about json-c library, it can be downloaded and reinstalled through the rpm command.

Thanks for all your help

I went ahead and reinstalled fresh after backing up my files, it seemed the whole thing was corrupted after the botched update.
I’ll run that test u suggested.
Thank you again