Fedora Media Writer error on Windows 7

I downloaded Fedora Media Writer from Fedora Workstation | The Fedora Project by clicking on the Windows icon, which links to https://getfedora.org/fmw/FedoraMediaWriter-win32-latest.exe. After downloading it, I ran that file, which installed Fedora Media Writer (mediawriter.exe). But then running Fedora Media Writer itself resulted in an error message. The titlebar of the dialog box said, “mediawriter.exe - Entry Point Not Found”, and the text inside said, “The procedure entry point CreateEventW could not be located in the dynamic link library api-ms-win-core-synch-l1-2-0.dll.”

I’m running the 64-bit version of Windows 7 Home Premium, with Service Pack 1.

Look: Mediawriter.exe - Entry Point Not Found · Issue #536 · FedoraQt/MediaWriter · GitHub

The developer says: “I’m afraid this is because Windows 7 is not supported by Qt 6. It looks it requires libraries that are not present on such old version of Windows.”

Thanks. I guess I’ll have to find some other way to make a bootable USB flash drive from a Fedora .iso. Do you have any suggestions?

Almost any burner is usually capable of directly writing an iso to a device. I have not used windows 7 so do not know what is available there.

A quick search for ‘how to write an iso to usb windows 7’ gave this as the first hit. https://neosmart.net/wiki/bootable-windows-usb/ which links to this “Easy USB Creator 2.0 by NeoSmart”.

Usually we recommend using rufus or etcher for the purpose.

1 Like

Thanks. Etcher worked.

1 Like