Fedora hangs on boot after upgrading to kernel 6.3.4

Sad to hear clearly something unique about your system.

In the bugzilla report re my bug, look through journalctl outputs therein and compare my 6.2.15 and 6.3.6 with your availble journal 6.2.15. Maybe you can see something that is uniquie in first 1000 lines. After that I’d say our system will wildly go different to mine. Just the boot part even first lines would give maybe a clue.

Again wild arse guess.

Please all, keep focused on the very problem we still have here, which is the one without nvidia.

@rairai9 You have no nvidia card. This is why nvidia-drm.modeset=1 does not suit your kernel.

Concerning 6.2.X kernels, this was about potential issues that are already logged at 6.2.X but that did not cause the 6.2.X kernels to break (so that it feels for you like there is nothing). So, I was seeking a hint that indicates why 6.3.X broke on your system. It was unlikely that 6.2.X already logged something that later caused another kernel to break, but it was worth a try.

 Booting a command list
EFI stub: UEFI Secure Boot is enabled.

Unfortunately, this is not indicative for us.


Since kernel 6.3.6 is already on its way, it is worth to hope for it to solve the issue. If you want to check it earlier, feel free to use bodhi to test it already now. For that, see: Fedora hangs on boot after upgrading to kernel 6.3.4 - #37 by py0xc3

If you do so, and if you want to give feedback in bodhi, please keep the “BZ#2211784” option neutral since your issue is a different one. But if 6.3.6 really solves your issue, you can add a comment to bodhi that 6.3.6 solves “BZ#2212012” (which is your bug report). Let’s hope…

If that does not work, I think we have to wait for the bug report to be processed. Unless someone else has time to play with your grub (which would end up in longer time investments). But I am not sure if that would make a difference. It any case, keep watching your bug report, and offer the information that people there ask for. Also, if 6.3.6 solves your issue, please let us know.

Also, you can keep watching F37 - 6.3.4-101.fc37 and 6.3.5-100.fc37 black screen after GRUB on AMD desktop, Nvidia laptop works and its related bug report (if that user adds one) → given that this user’s system is able to mount root, I assume this is a different bug. But since the hardware is completely different while using F37 (you F38), it is also possible that the same bug just behaves different on his system. So it is worth to keep checking if something comes up that solves their issue, and if so, let’s see if that helps you too. If that user finds a solution, feel free to trigger me here with @py0xc3 so that I can transfer his solution to your machine (do not just do what they do! It’s F37).

@py0xc3 I’ll just wait until 6.3.6 becomes a regular update and then test it out, thanks! I’ll let everyone know if that kernel works for me.

Sounds like a plan :wink:

@py0xc3 I just upgraded to kernel 6.3.6 and I still have the same issue as I did with kernels 6.3.4 and 6.3.5, sadly. I updated my bug report with this new info.

Hi.

I think, I have similar problem. Kerenl 6.2.15 is the last one, what works fine.

My computer doesn’t have any NVIDIA and AMD parts.

Having the same issues as @rairai9 and @glewik . The output of cat /proc/sys/kernel/tainted is 0 for me as well. There are no logs present in journalctl for the unbootable kernels (6.3.4 and above) once I boot with a working one (6.2.15)
Fortunately I was able to grab some logs with journalctl while booting with 6.3.6 and removing the rhgb quiet part from the command.
Please refer to the attached imgur album : Imgur: The magic of the Internet

Failed to mount sysroot.mount
Dependency failed for initrd-rootfs.target
Dependency failed for initrd-parse-etc.service

@rairai9 we became just aware that the template of the kernel bug report has been broken (it seems to no longer ask for some information). I assume the bug report did not ask you for dmesg. Could you add this now? So get the output of dmesg and add the file/link to the bug report (please do not paste the content as comment). Also note that the dmesg is taken from 6.2.15.

@ all others:
IF YOU FULFILL ALL OF THE FOLLOWING CONDITIONS:

  • output of cat /proc/sys/kernel/tainted returns 0.
  • the “symptoms” / behaviors are the same as that of Sean / @rairai9 when you boot the current kernel 6.3.6
  • You use F38 on x86_64 (you can find out both with uname -r)
  • 6.2.15 is the newest kernel that works.

In this case, add a short note to the bug report of Sean and note that you have the same issue, so that we can consolidate a little if and how far this is a wider phenomenon. But please do only add a short note without journals, logs or so: Just inform that cat /proc/sys/kernel/tainted returns 0 and that you have the same issue as Sean with 6.3.6 on F38/x86_64.


Those with F37: please check F37 - 6.3.4-101.fc37 and 6.3.5-100.fc37 black screen after GRUB on AMD desktop, Nvidia laptop works

I am not able to check content of this file when i am trying using kernel higher than 6.2.15. When I using kernel 6.2.15 result cat /proc/sys/kernel/tainted is 0

3 posts were split to a new topic: Fedora enters emergency mode with all kernels after 6.2.14-300.fc38.x86_64

@py0xc3 I just added the output of dmesg to the bug report as an attached text file since the template didn’t ask me for it originally. Hopefully this will help the issue get resolved! Please let me know if there are any other logs/reports I should attach to the bug report. Thanks!

It’s strange. Today when I turned on my laptop, it’s running on the latest kernel. The laptop working until second reboot. Now again, I can working only on kernel in version 6.2.15 and lower.

If I good remember yesterday evening, I was check some options in the BIOS.

Bellow is my link to boot-log on lastest version.

@glwwick Glad you are now able to boot a current Fedora kernel.

This does mean your issue was not the same as the one in this thread. Small details can be important to understanding problems with linux.

Now that you can boot, your adventure may continue with power management and sound issues.
If you need more help, please start a new thread and provide enough detail to allow others to reproduce the problem. Please include, in searchable text format using the </> button, the output of inxi -Fzx for your system.

That should be fine for now. I know you haven’t been asked. I saw that issue in multiple kernel bug reports and this is why I checked it and saw myself that there is currently no template at all. But the team is informed, so I assume the kernel bug report template is repaired soon.

Just keep watching the bug report and provide requested information if someone asks you there.


Is that the log of the one 6.3.6 boot that worked? Or is that a 6.3.6 boot that was broken?

My ASUS Vivobook S 14 Laptop (CPU: i5-12500H, GPU: Iris Xe, no dedicated graphics) is unbootable after upgrading to kernel 6.3.4 and above. But when I plug something into one of the usbc ports before turning on my laptop, kernel 6.3.5, 6.3.6 and 6.3.7(installed from bodhi) can boot without issue.

After unplugging everything from the usbc ports, I added module_blacklist=ucsi_acpi to grub kernel command line and successfully boot with kernel 6.3.6 and 6.3.7 .

I guess @glewik and @squidward also use Vivobook S laptop. Blacklisting kernel module ucsi_acpi may solve the problem for you.

It’s look like works. Thank you @fives . I’m wondering how will be look energy consumption now, and where did you find this solution?

Seems you found the bug. Thanks for letting us know!

I suggest to mention in the bug report if and for whom module_blacklist=ucsi_acpi solves the issue.

Also, if the blacklisting solves the issue for you, I suggest to add your dmesg output along with the information (please add the file or a link, do not paste the content as comment!).

It is possible that developers will ask you for more information to identifying the bug.


Just a side note, but I suggest all to try once 6.3.7 when it is released without blacklisting. Just to ensure that it remains necessary to keep the blacklisting (the same for future kernels).

Finally, this should not be a long term solution.

Thank you @fives ! I have the same laptop. The solution also worked for me. Kernel 6.3.6-100. Before the event (module_blacklist=ucsi_acpi) the only working boot was with kernel 6.2.15-200.

The dmesg output has cze 10 05:55:36 asus kernel: ucsi_acpi USBC000:00: PPM init failed (-110). ACPI is a cross-platform standard (despite Bill Gate’s efforts to make it Windows only!). Searching for ucsi_acpi PPM init failed (-110) will reveal many instances of problems with ucsi_apci in multiple linux distros.

Disabling, the module may be a quick workaround if you don’t use USB-C. Some reports say the problem is fixed with updates or after removing all power (not always possible for laptops).