Fedora enters Setup (as if in a fresh install) after Gnome 43 update

Hello all :slight_smile:
Just for context: I am not a linux-noob nor pro - I’ve used Arch and Manjaro before and now (after a few years of break) Fedora 36 Gnome.

I was learning and exploring ZSH and some new terminals, when I received an update in Software center for Gnome 43 - I updated, and after it installed I waited for a little while maybe 15ish minutes, for the background tasks to finish. I ran reboot from Gnome terminal and then when my laptop booted back up it showed the “Setup” prompt.

I tried exiting but I cannot. If I try to create a new user and type my original user name I receive a message saying that the user name is not available - which makes me think that my user profile is still there in the system, but I can’t boot into it for some reason.

I don’t know what to do. I tried finding a solution online but I can’t find any similar problems/solutions.

All help is greatly appreciated - I would love to save my files at least.

Thank you,


New information
When booting, I press F8 to see GRUB menu and I have 2 versions of Fedora kernel, 5.19. and 5.17. & when I select the 5.19. there is only my laptop logo and Fedora logo on a black screen. Now I have even less clue what to do and what the problem might be.

try making
user with other name cause you can after delete it anyway

Hey thanks for reply.
I could do that, i didn’t think of it - thank you, but is it possible to somehow get access to my original user?
(Can I access original user’s data as a hypothetical new user?)

cause gnome-initial-setup
is executed at root
to create ADMINISTRATOR account
and admin can acces every file on the disk
But actually i think that logout options will show you list of users
and there should be your previous one

1 Like

Thank you!

1 Like