Fedora 36 : Gnome-initial-setup blocks access to already existing user account

Hi to the Fedora community !

Fedora 36 workstation has been running very smoothly on my laptop for a couple of weeks but today, on startup, there is no screen to log in with my user account but the Gnome-initial-setup starts and basically blocks the access.

No special operation was done the day before, and that was a bit scary as it gave the impression that the whole system got somehow reset and data was lost.

I could access data on the HDD: user account data is still there, looks like that the filesystem also shows the additional programs that I installed.

On the boot menu, there are three Fedora entries but each of them leads to that initial set up, which seems to require the creation of a new user account.

What can be done please?

  • eg, if a new user is created, would it just create an additional user account and leave existing user data as is, or would it wipe the home directory and replace everything with the newly created account?
  • what can be the root cause of such a “replay” of the initial set up and is there a way to bypass it, either through the screens or by addressing the issue in the file system?

Many thanks !


Hey welcome to ask fedora, please take a minute to read, https://discussion.fedoraproject.org/t/welcome-to-ask-fedora-please-read-me-first/7

It shouldn’t overwrite the existing user as long as you use a different user name.
e.g. If your original user was bob, make your new user bob1 or 1bob

Once the initial gnome login screen is displayed:
Press ctrl + alt + F3
From here you should be able to login with your user name into a terminal session.

I would then start with looking at:
cat ~/.config/gnome-initial-setup-done
It should just say yes
If the file doesn’t exist you should be able to create it with: ’
echo “yes” >> ~/.config/gnome-initial-setup-done

I would also check disk usage:
df -h


Hi Joe,

Many thanks for the fast response and for the welcome!

With your inputs, I could try the following:

  • check, in my data, gnome-initial-setup-done => there is a file with “yes”
  • check disk usage : no issue there, loss usage level on each volume
  • interrupt the setup with ctrl + alt+ F3 : works but couldn’t log in (seems it switches to the standard US keyboard, just like for the passphrase input for the 4 Fedora entry - recovery - at boot but will try again with the exact keyboard layout)
  • created a new user, could log in, everything still installed, terminal window works fine.

However, when I logged out from that newly created user account, I didn’t see my initial user listed as a possibility to log in. I tried to log in and it works but the terminal window crashes immediatly when I start it.

I tried to find a similar issue in this forum, and also online : the only similar issue is that one going back to… Fedora 6 : seems to be the same behavior.


Any other possibility please ? But again, things were so far fine and no special action was done.



can you check:
cat /etc/passwd | grep -i "insertyourusernamehere"
What we’re looking for is the last part of it. It should say something like:
:/bin/bash or :/usr/bin/zsh depends on the shell you’re using.

What is the last thing you remember working on prior to this occuring?

1 Like

Hi Joe,

Many thanks again for being so responsive!

So the answer to checking cat /etc/passwd | grep -imyusername is /bin/false

I have reviewed the following links to know a bit more on this:

So having done this change in /etc/passwd from the new user account, I could log out and then, the log in screen displayed the 2 users accounts. I could log in to my former account, check if things seem to work and also change the password.

As to what I did on my computer before that happened, I checked the bash history : I had looked a few things in nftables (but no changes), did a dnf update and installed maldet. The first scan done with maldet didn’t return any hit, except two maldet files. I also used that day gnome-boxes, when I run among other a Fedora Silverblue image to explore a bit how it works.

I also thought to check the reboots on this system, but unless I misread the log, there are no entries for the day before the issue (Sunday 6) so that log may show some discrepancy or lack of data. If this kind of incident usually gets looked at to see if it may have happened to other users as well, I can share logs if need be.

So thanks a lot Joe for your help and for bringing the solution, really appreciated !

Kind regards,


1 Like

It seems that maldet is able to quarantine users, so it is likely that is what has happened.

I found this in the file maldetect-1.6.4/files/internals/functions

   /usr/sbin/usermod -s /bin/false $user >> /dev/null 2>&1

Hi Villy @vekruse,

Many thanks for this insight, very much appreciated!

That appears likely indeed and if I may ask another question on this please: I have used Maldet for a certain amount of time - but not lately - on other Linux distributions (should not admit that maybe: :slight_smile: ) without getting that kind of event, so would you know if this has been introduced recently or what are the conditions that may trigger this behavior?

Kind regards,


I don’t know. You may need to ask the author of the package.

By the way, using another linux distribution is nothing you need to hide.