Fedora CoreOS rebasing to Fedora 33: features and known issues

Originally posted on coreos-status.

Over the next two days we’re planning to release and rollout the first Fedora 33 based FCOS into the stable stream.

New features include:

Some notable issues/configurations:

Thanks to everyone who participated in the test day and to everyone that run the testing and next streams to help us identify and fix issues before they get to stable.

Dusty Mabe, for the Fedora CoreOS team

9 Likes

I might have experienced an issue due to the rebase. I run a fedora coreos baremetal arm server with a podmanized tvheadend. Somehow since I deployed it the dibusb dvb modules get loaded but the /dev/dvb/adapter0 does not get created. Strangely enough, no meaningful kernel error/warning on journalctl.

I tried to install FCoreOS to “baremetal” to an old notebook, but the baremetal ISO failed to boot.

ISOs are written to the same USB stick, that old notebook Boots:

  • F33 Netinstall - OK
  • F33 Silverblue - OK
  • F33 Workstation Live - OK
  • F33 CoreOS Stable - Failed
  • F33 CoreOS Test - Failed
  • F33 CoreOS Next - Failed

For comparison, another notebook boots the F33 CoreOS USB OK.

Failed means the Local HDD bootloader is booted instead of the one from the USB media.

Further testing the CoreOS stable USB media on a Desktop machine:

  • UEFI boot failed - dropped to grub shell
  • BIOS boot OK. After installation, switch to UEFI still booted OK.

Can you file an issue in the tracker with more details about the hardware and the error you’re hitting?

Issue created: coreOS Installation USB Media boot Failed but Workstation Media booted OK · Issue #724 · coreos/fedora-coreos-tracker · GitHub

dmidecode outputs of my two failed machines posted as separate comments over there.

I may have missed the point here, but where are you getting your coreOS bare metal image from? When I did a bare metal install (version 32) a couple of months back I noticed that the image from the download page (for some reason) is not a bootable ISO. I had to use the following to create a bootable ISO suitable for booting from a USB drive:

podman run --privileged --pull=always --rm -v .:/data -w /data quay.io/coreos/coreos-installer:release download -f iso

Thanks for pointing out, I should stated more clear where I got the ISO from.

The ISOs I tested are bootable, as the same USB created from it is booting OK in my Dell Vostro Notebook, while failed in my Sony notebook, and in my Desktop: BIOS OK, UEFI failed.

I get from getfedora.org
https://getfedora.org/en/coreos/download?tab=cloud_launchable&stream=stable

https://builds.coreos.fedoraproject.org/prod/streams/stable/builds/33.20210104.3.0/x86_64/fedora-coreos-33.20210104.3.0-live.x86_64.iso
https://builds.coreos.fedoraproject.org/prod/streams/testing/builds/33.20210117.2.0/x86_64/fedora-coreos-33.20210117.2.0-live.x86_64.iso
https://builds.coreos.fedoraproject.org/prod/streams/next/builds/33.20210117.1.0/x86_64/fedora-coreos-33.20210117.1.0-live.x86_64.iso