Fedora CoreOS on DigitalOcean?


Has anyone tried deploying a Fedora CoreOS droplet on DigitalOcean lately?

I’m in the process of experimenting with it, and while I can get a droplet to launch with the custom image taken from the stable stream (fedora-coreos-36.20220522.3.0-digitalocean.x86_64.qcow2.gz), the droplet comes up without functional networking of any kind. My ignition file does nothing other than set a username, password, and SSH key, and the documentation doesn’t mention doing anything more than this.

Is this supposed to work without extra configuration?

1 Like

Interestingly, trying this again hours later… All of the instances started up with full networking.

There may be some kind of initialization race condition, because this failed multiple times earlier, but now isn’t failing anywhere.


To be clear, I’m not certain this is “solved”. The problem didn’t happen later in the day, but it did happen repeatedly earlier in the day. There may be an underlying issue here!


This doesn’t solve anything, but I administer kubernetes clusters in my dayjob and this kind of stuff is a maddeningly not uncommon thing (and not just FCOS…). It’s definitely the world of “just keep rebooting and restarting stuff until something works”.