Fedora command not working

This command always worked for me in fedora 26

dnf install -y firefox x2go*

But it now gives an error:

"Command ‘dnf’ not found, did you mean:

command ‘df’ from deb coreutils (8.30-3ubuntu2)

Try: apt install "

Question: How do I make this command work in Fedora 32?

What? Weird. Are you really sure that you are using Fedora?


APT is the package manager/dependency solver for the Debian ecosystem, i.e. it manages .deb packages installed by the DPKG program. Fedora software is based on .rpm packages, and thus uses DNF, the package manager/dependency solver for the RPM program, instead. This document gives a brief overview of the most common APT commands one might find in tutorials and their DNF equivalents.


@florian That does not answer his question.
DNF should work for him unless he has gotten confused and tried a fedora command on a different machine.

@ineedhelp12341 could you run the command uname -a and post the result here so the rest of us are certain we are providing the proper information to assist you.

2 posts were split to a new topic: Kinoite: dnf command not working