Fedora 40 won't boot after installing nvidia video driver


I recently formatted my computer and during the initial setup of Fedora, I encountered a significant issue with the video driver. I followed the tutorial provided at (Howto/NVIDIA - RPM Fusion), and proceeded with the recommended installation for my hardware (Current GeForce/Quadro/Tesla) using the following commands:

sudo dnf update -y # and reboot if you are not on the latest kernel
sudo dnf install akmod-nvidia # rhel/centos users can use kmod-nvidia instead
sudo dnf install xorg-x11-drv-nvidia-cuda # optional for cuda/nvdec/nvenc support

After waiting a few minutes, my PC simply froze on the boot screen indefinitely, making it impossible to use and significantly delaying my work. I’m currently using an older kernel version, for some reason when I boot into it the NVIDIA driver crashes and I revert to using Noveau.

(sorry for the quality) this is the loading screen stuck, I can’t even see GDM.

System Details Report

Report details

  • Date generated: 2024-06-18 10:49:56

Hardware Information:

  • Hardware Model: Dell Inc. Dell G15 5530
  • Memory: 8.0 GiB
  • Processor: 13th Gen Intel® Core™ i5-13450HX × 16
  • Graphics: Intel® Graphics (RPL-S)
  • Graphics 1: Intel® Graphics (RPL-S)
  • Disk Capacity: 256.1 GB

Software Information:

  • Firmware Version: 1.14.0
  • OS Name: Fedora Linux 40 (Workstation Edition)
  • OS Build: (null)
  • OS Type: 64-bit
  • GNOME Version: 46
  • Windowing System: X11
  • Kernel Version: Linux 6.9.4-200.fc40.x86_64

Is ‘Secure Boot’ enabled? If so, then you probably skipped an important part in the install procedure.

follow these instructions Howto/Secure Boot - RPM Fusion

with keys enrolled, re-create the nvidia kernel modules ‘akmods --rebuild’ or akmods --force’’ can’t remember which one.

UPDATE: this seems to be related

Hello Mark,

I forgot to mention in the main post, but yes, my secure boot is disabled. I’ve also tried doing it the way you recommended, signing the driver with secure boot enabled (still no solution). And it seems that the creator of the related post didn’t find a solution either…

I tried removing the packages I had installed and booted into the latest kernel to try to use the PC without the driver for now. However, now my VSCode won’t open, and several applications are crashing (I don’t know if the issues are related).
I’m facing a lot of problems here. :slightly_frowning_face:

Screenshot from 2024-06-18 12-04-11

What is the output of 'lsmod |grep -e nouveau -e nvidia
and ‘rpm -qa nvidia\*’?
The last command should list a nvidia-gpu-firmware package. If not then install and reboot.

the conclusion of the related topic (same HW) was a nvidia driver error. Does problem report or the command coredumpctl show something related?

there is a BETA driver of the upcoming Nvidia 560 driver available. You could try installing this driver. The install process is documented here

The last command didn’t return any output, how do I install the firmware? I currently don’t have the driver, so should I follow the tutorial again? If you can help me I would be very grateful.

Below are the outputs of the specified commands

dnf install <package name>

try first with firmware installed.

if nouveau driver works good enough for you than probably keep using it for now.
otherwise try the beta driver (have not tried that one).

Update: you removed the firmware with the removal of the nvidia driver. This happens if you do something like dnf remove \*nvidia\*. The nvidia firmware package must not be removed if you have a nvidia gpu.