Fedora 39 Xfce: Suspends only proceeds after unlocking the screen

Hello,
I’ve updated from Fedora Linux 37 to 39. I am using Xfce.

I’m using slock as my screen locker and I have enabled screen locking on suspend:

$ xfconf-query -c xfce4-session -p /general/LockCommand 
slock
$ xfconf-query -c xfce4-session -p /shutdown/LockScreen
true

On Fedora 37, when I suspended my computer, via the Log out dialog, the following happened:

  1. the screen went black, as slock started
  2. in a ~second, the screen went blank, as the computer suspended
  3. (after hitting a key to wake up) the screen was black and later blue, allowing me to type my password to unlock

On Fedora 39, however:

  1. the screen goes black, as slock starts
  2. the computer does not suspend
  3. when I press buttons, the screen goes blue, allowing me to type my password
  4. (after unlocking slock) in a ~second, the screen goes blank, as the computer suspends
  5. (after hitting a key to wake up) the desktop is not locked

This is quite inconvenient. Any idea how to debug this further or fix it? I’d like to have my system locked when I suspend it.

What does
‘xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/lock-screen-suspend-hibernate’

and
‘xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/logind-handle-suspend-key’

show?

and what version of xfce4-power-manager do you have there?

$ xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/lock-screen-suspend-hibernate
true
$ xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/logind-handle-suspend-key
Property "/xfce4-power-manager/logind-handle-suspend-key" does not exist on channel "xfce4-power-manager".
$ rpm -q xfce4-power-manager
xfce4-power-manager-4.18.2-2.fc39.x86_64

I’ve checked and the only logind property I see is /xfce4-power-manager/logind-handle-lid-switch (set to false).

Thats all correct looking. ;(

I did just build xfce4-power-manager-4.18.3 if you want to try it (in
updates-testing soon). I don’t see anything obviously related to this
though. ;(

Still the same with xfce4-power-manager-4.18.3-1.fc39, even after restarting :frowning:

Yeah, didn’t think that would help.

Does it work as expected when you use xfce4-screensaver instead of
slock?

I get “Failed to lock the screen” and when I attempt to run from the terminal xfce4-screensaver, it tells me an instance of it is already running.

What is your xfconf-query -c xfce4-session -p /general/LockCommand?

I’ve also noticed the screen does not go off when the computer is idle. Might be related (or not).

Seems to be the same case as in display does not turn off / Desktop / Xfce Forums