Fedora 37 on ASUS laptop, kernel list not shown on boot

I have been using Fedora for a while, but I am far from being an expert. I have an ASUS laptop. It recently was running Windows 10. When my Dell laptop that was running Fedora died, I installed Fedora 37 on the ASUS via a live update USB. With all of my previous versions of Fedora, when booting, I had a menu of several (3) kernels to choose from. With Fedora 37 on the ASUS, I do not get this menu, but the latest kernel starts booting. I have not been able to determine why this has changed. Other users discussing Fedora 37, mention the kernel menu, so I think something was done in the install, or in the ASUS bios that prevents grub from presenting the kernel menu or makes the choice for it. I list below the output of lshw for the latptop, the firmware, and the processor. Please let me know what I can do to return to having the kernel list. There were times on the previous laptop where I had to backup to a previous kernel. Thanks for any help.

description: Notebook
product: K56CA (ASUS-NotebookSKU)
version: 1.0
serial: CBN0CV517714484
width: 64 bits
capabilities: smbios-2.7 dmi-2.7 smp vsyscall32
configuration: boot=normal chassis=notebook family=K sku=ASUS-NotebookSKU uuid=80FC73A2-C062-E381-21A1-08606E0EA1E7
description: Motherboard
product: K56CA
physical id: 0
version: 1.0
serial: BSN12345678901234567
slot: MIDDLE
description: BIOS
vendor: American Megatrends Inc.
physical id: 0
version: K56CA.207
date: 09/19/2012
size: 64KiB
capacity: 6MiB
capabilities: pci upgrade shadowing cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer acpi usb smartbattery biosbootspecification uefi

      description: CPU
      product: Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz
      vendor: Intel Corp.
      physical id: c
      bus info: cpu@0
      version: Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz
      slot: SOCKET 0
      size: 952MHz
      capacity: 3800MHz
      width: 64 bits
      clock: 100MHz
      capabilities: lm fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp x86-64 constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm cpuid_fault epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt dtherm ida arat pln pts md_clear flush_l1d cpufreq
      configuration: cores=2 enabledcores=2 threads=4

When the previous boot is OK, grub2 will default to hide boot menu and boot directly.

Please see the above thread.

Grub2 has always (for me) shown the grub menu on dual boot systems, and hides it if fedora is the only system installed.
It is possible that you erased windows when you installed fedora 37?

The command shown sudo grub2-editenv - unset menu_auto_hide should enable the grub menu for all systems. If that command does not work or gives an error message you might try it as sudo grub2-editenv - unset "menu_auto_hide"

Thanks, that fixed it. This install of Fedora 37 was by live update. I had not done that since about Fedora 27-28. I had looked briefly at grub2 doc, but did not find it. I appreciate all of the help I have received from “Ask Fedora”.