Fedora 37 NVIDIA kernel module missing. Falling back to nouveau

I followed this tutorial Howto/NVIDIA - RPM Fusion to install NVIDIA drivers. After rebooting, “NVIDIA kernel module missing. Falling back to nouveau.” shows up on startup.

GPU: NVIDIA GeForce 920M
Driver version: 470.103.01

I already tried:

  • Reinstalling driver
  • Disabling secure boot
    akmods --force && sudo dracut --force returned:

Checking kmods exist for 5.19.11-300.fc37.x86_64 [ OK ] Building and installing nvidia-470xx-kmod [FAILED] Building rpms failed; see /var/cache/akmods/nvidia-470xx/470.103.01-1-for-5.19.11-300.fc37.x86_64.failed.log for details

Hint: Some kmods were ignored or failed to build or install. You can try to rebuild and install them by by calling '/usr/sbin/akmods --force' as root.

Logs: https://privatebin.net/?3d495476eaf371c1#FpdoVFqwiGRmi2ocYBSgTZBui99b88JnHAB55vSNk23N

1 Like

Do you have kernel-devel and kernel-headers installed in the system so the driver can build.

1 Like

Yes, I have them both installed.

It is possible that some step was missed in following that tutorial.

What is the output of dnf list installed *nvidia*? and dmesg | grep secure

dnf list installed *nvidia*
Installed Packages
akmod-nvidia-470xx.x86_64                  3:470.103.01-1.fc36 @rpmfusion-nonfree-nvidia-driver
nvidia-gpu-firmware.noarch                 20220815-139.fc37   @fedora          
-nvidia-persistenced.x86_64                 3:515.65.01-2.fc37  @rpmfusion-nonfree-nvidia-driver
nvidia-settings-470xx.x86_64               3:470.103.01-1.fc36 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-470xx.x86_64           3:470.103.01-1.fc36 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-470xx-cuda.x86_64      3:470.103.01-1.fc36 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-470xx-cuda-libs.x86_64 3:470.103.01-1.fc36 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-470xx-kmodsrc.x86_64   3:470.103.01-1.fc36 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-470xx-libs.x86_64      3:470.103.01-1.fc36 @rpmfusion-nonfree-nvidia-driver
dmesg | grep secure
[    0.000000] secureboot: Secure boot disabled
[    0.011281] secureboot: Secure boot disabled

I don’t know if that is a result of using f37 which is still beta or not, but you have many of those packages as f36 and some as f37.

I just did an upgrade of my F37 VM and did an install of the akmod-nvidia-470xx package from rpmfusion-nonfree and I got this.

# dnf list installed kernel*
Installed Packages
kernel.x86_64                                                      5.19.10-300.fc37                                        @updates-testing
kernel.x86_64                                                      5.19.11-300.fc37                                        @updates-testing
kernel.x86_64                                                      5.19.12-300.fc37                                        @updates-testing
kernel-core.x86_64                                                 5.19.10-300.fc37                                        @updates-testing
kernel-core.x86_64                                                 5.19.11-300.fc37                                        @updates-testing
kernel-core.x86_64                                                 5.19.12-300.fc37                                        @updates-testing
kernel-devel.x86_64                                                5.19.12-300.fc37                                        @updates-testing
kernel-devel-matched.x86_64                                        5.19.12-300.fc37                                        @updates-testing
kernel-headers.x86_64                                              5.19.4-300.fc37                                         @updates-testing
kernel-modules.x86_64                                              5.19.10-300.fc37                                        @updates-testing
kernel-modules.x86_64                                              5.19.11-300.fc37                                        @updates-testing
kernel-modules.x86_64                                              5.19.12-300.fc37                                        @updates-testing
kernel-modules-extra.x86_64                                        5.19.10-300.fc37                                        @updates-testing
kernel-modules-extra.x86_64                                        5.19.11-300.fc37                                        @updates-testing
kernel-modules-extra.x86_64                                        5.19.12-300.fc37                                        @updates-testing
kernel-srpm-macros.noarch                                          1.0-15.fc37                                             @fedora         

# dnf list installed *nvidia*
Installed Packages
akmod-nvidia-470xx.x86_64                                                  3:470.141.03-2.fc37                           @rpmfusion-nonfree
kmod-nvidia-470xx-5.19.12-300.fc37.x86_64.x86_64                           3:470.141.03-2.fc37                           @@commandline     
nvidia-gpu-firmware.noarch                                                 20220815-139.fc37                             @updates-testing  
nvidia-settings-470xx.x86_64                                               3:470.141.03-2.fc37                           @rpmfusion-nonfree
xorg-x11-drv-nvidia-470xx.x86_64                                           3:470.141.03-2.fc37                           @rpmfusion-nonfree
xorg-x11-drv-nvidia-470xx-kmodsrc.x86_64                                   3:470.141.03-2.fc37                           @rpmfusion-nonfree

Note that I have the kmod-nvidia-470xx package built for the newest installed kernel that was also newly installed. All the nvidia packages installed are for f37 and none are for f36.

This may very easily be due to the fact that you are using the rpmfusion-nonfree-nvidia-driver repo which is not yet available for auto enabling via the gnome software panel on f37.


I then removed the nvidia drivers I had just installed and reinstalled them from the rpmfusion-nonfree-nvidia-driver repo.

  akmod-nvidia-470xx-3:470.141.03-2.fc37.x86_64                  kmod-nvidia-470xx-5.19.12-300.fc37.x86_64-3:470.141.03-2.fc37.x86_64     
  nvidia-gpu-firmware-20220815-139.fc37.noarch                   nvidia-settings-470xx-3:470.141.03-2.fc37.x86_64                         
  xorg-x11-drv-nvidia-470xx-3:470.141.03-2.fc37.x86_64           xorg-x11-drv-nvidia-470xx-kmodsrc-3:470.141.03-2.fc37.x86_64             


# dnf list installed *nvidia*
Installed Packages
akmod-nvidia-470xx.x86_64                                       3:470.103.01-1.fc36                        @rpmfusion-nonfree-nvidia-driver
nvidia-settings-470xx.x86_64                                    3:470.103.01-1.fc36                        @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-470xx.x86_64                                3:470.103.01-1.fc36                        @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-470xx-kmodsrc.x86_64                        3:470.103.01-1.fc36                        @rpmfusion-nonfree-nvidia-driver

Note that now I only have the f36 packages, they are for version 470.103 instead of 470.141, and it failed to build the kmod-nvidia package.

I would strongly suggest that for f37 you do the following.

  1. sudo dnf remove *nvidia* --noautoremove --exclude=nvidia-gpu-firmware
  2. sudo dnf install akmod-nvidia-470xx --disablerepo rpmfusion-nonfree-nvidia-driver --enablerepo rpmfusion-nonfree
  3. Wait 5 minutes then run dnf list installed *nvidia*
    If that last command shows kmod-nvidia as installed then reboot and the nvidia card should now properly load the nvidia driver.

Thanks! It’s working now.

1 Like

remember to read full instructions
ex. rpmfusion documentation

I don’t now if it’s ok for me to jump in but should the secure-boot be disabled and if so how? I’m having the same problem. I’m running a NVIDIA Geforce GTX 1660ti on fedora 37

1 Like

Welcome @smithapproved to ask :fedora:

Shortly after a new boot, please run uname -a and dmesg | grep -iE 'secure|nvidia|nouveau' and post the result of both commands here using the </> Preformatted text tags on the toolbar above the input window.

1 Like

Thank you for this, just upgraded from 36 to 37 and this last 3 step worked great for me.

1 Like

Just upgraded from 36 to 37 but getting same error on boot up

I ran the commands here are the results .

Can this be fixed ?
I see turning off secure boot fix this and if so is it safe?
Or is it just removing the message?

Thanks. The last 3 commands did it for me.

Turning off secure boot is safe for most users.

Alternatively, if you wish to keep secure boot active, you can sign the nvidia driver modules following the instructions at rpmfusion.

After the reboot and enabling the key in that procedure then remove and reinstall the required portions of the drivers with sudo dnf remove \*nvidia\* --exclude=nvidia-gpu-firmware followed by sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda. After the reinstall wait 5 minutes for the modules to be built properly then reboot and the system should now load the signed nvidia modules.

1 Like

Thanks alot, it is working, but the system wont regconize gpu sensor any more, it cant read the temp or the frequency.

If you are using lm_sensors you may need to run sensors-detect since the driver for the GPU has changed.


Thanks for interjecting, but being critical of what has worked for others is not the best policy.

My comment was correct. If everything went well when akmod-nvidia is installed then the akmod-nvidia package will trigger a build of kmod-nvidia. Once the kmod-nvidia package has been built then a reboot should load the modules. If kmod-nvidia is not built and not identified as available for the kernel being booted then the modules are not available to load.

1 Like

It wasn’t absolutely in my purpose to be critical to your answer Jeff.

I tried to use the most humble words available to my knowledge of the English language. Even so, if I’ve been unable to communicate my experience (fedora 37 KDE Plasma) where -I thought- the message from the OS could be different, it’s only my fault.

On the 1st phrase, after the comma It was more appropriate to write “shouldn’t it be” rather than “It should be”. Even when I’ve started the sentence with “Maybe…” and started the 2nd paragraph “Sorry if I’m mistaken…” and even tried to put a little bit of humor, If the message can be misunderstood It’s my fault (the sender is the only responsible for the quality of the message), so I hope you accept my apologies.

The only must left is delete that post and keep myself on the simplest and most direct expressions to avoid screwing it up again at this forum.

One literal apology and one thousand thanks for helping me solving my issue with my driver.

PS.: I’m really a newbie on Linux and even more on this forum, I tried to answer you on a private message but I’ve been unable to. So I’ll delete this post too once I noticed you read it and change it to another one shorter and direct.

No problem. Please do not delete your second post. In fact deleting the first one now puts mine out of context.

My comment was not meant to insult and I was not insulted. I merely wanted to point out that we all have to be careful in phrasing to avoid conflicts. After all, the general guidelines here are “be excellent to everybody” so we all need to read twice before posting once, and judge how others may interpret what we say. I apologize if that offended, as it was not intended that way.

I still feel, that since my post you referred to was related to expected results the statement was correct. If the install did not put the akmod in place other errors would be seen, but only a proper install of the akmod-nvidia package and other supporting packages could be expected to then build the kmod-nvidia package on the system.

Welcome to the ask :fedora: community and I will try to be a little better in my comments and hope you accept my apology as well.

1 Like

Piece of cake!

Even when the in “my machine” (fedora 37 KDE - nvidia driver 390xx) dnf list installed *nvidia* didn’t show any kmod-nvidia, I’ve rebooted and everything went as expected. Maybe the desktop or the driver version are involved in that third step issue, so if you are in the same scenario it could help wait several minutes (to be safer) and reboot anyways, but take this suggestion as a pinch of salt.

I was assuming to revert f36, but these three statements allowed me to go on so I can’t be more grateful to Jeff ant the forum.

Keep it up!
*(no typo, no h at the end of my name, it’s a Catalan name :sunglasses:).

PS.: I felt welcome to the ask :fedora: community from the first login. And this feeling is getting better and better all the way.