Fedora 35, x11 and nvidia driver 495.44: "Failed to set new Fan Speed"


Create a new file in the “/etc/X11/” directory

# sudo nano /etc/X11/Xsession.options

save/logout/login and works fan speed settings

1 Like

Kenel update (Fedora 35) and it doesn’t work again.

1 Like

Same here. This is shame since I have fresh install. I also got error: nvidia-gpu 0000:26:00.3: i2c timeout error e0000000 on every boot.

On PopOs and Ubuntu same driver works without errors


Did you have custom scripts inside .bashrc or anything related to user environment?

Ok so after googling around and testing everything I finaly found solution!

In this driver you must make X run as root to access OC and thermal setting. So what I needed to do was edit Xwrapper.config

nano /etc/X11/Xwrapper.config

Fix these lines:

Then go same folder and type:
sudo chmod 2644 /etc/X11/Xwrapper.config


I tested drivers 470.86 and 495.44 and this worked with both

Warning take backup to xrapper before edit!

1 Like

I do not have the /etc/Xwrapper.config file and I also have the problem of not being able to manually set the fan speed.

On my laptop it is not an issue since the fan speed is controlled by the CPU load/temp, but on my desktop the fans on the gpu card have always been self-controlled even though the temp has sometimes gotten a bit higher than I like.

What is the actual content of /etc/X11/Xwrapper.config?
What is the ownership to go with the permissions you set?
Where did that file come from originally? I am interested since I don’t have it.

If Xorg has determined he can run as a non-root user it seems wise to keep it that way.

Instead I would use sudo nvidia-settings to first verify if FAN control can be enabled, but it seems a crazy option, better not to touch the value here… Also I wonder if all card support that option… (I haven’t verified anything in the code).

IMO, the bug should be reported to nvidia (using devtalk.nvidia.com).

The issue, AFAICT, is that nvidia-settings by default is unable to make fan speed changes. I have tried on both my systems with the same dead end.

Not nvidia bug, missing xorg settings and file!

I kindly disagree here.
You are reverting a security feature Changes/XorgWithoutRootRights - Fedora Project Wiki

Also some more info here: 465.24.02 - No longer able to set Graphics Clock Offset and Memory Transfer Rate Offset - Linux - NVIDIA Developer Forums

Unfortunately this is not the process for reporting bugs to nvidia.
You need to use the devtalk.nvidia.com forum.

You have to make that file and It works after that. Fedora installer does not create Xwrapper.config

sudo nano /etc/X11/Xwrapper.config

Ad these two lines:

Save file

Then go same folder and type:
sudo chmod 2644 /etc/X11/Xwrapper.config


If you want revert just delete Xrapper.config

1 Like